Simple Software for a Simple Life!
Simple Software for a Simple Life!
INFO: Working with Lists on Windows PC
Views: 3412 Created: 08-10-2010 23:45 Last Updated: 08-31-2011 10:53

You can use the selections on ListPro's Edit, View, Items, and Tools menus to customize your lists' appearance and functionality.

View Menu

ListPro's View settings allow you to select just how you want to see your list.

List on Left puts the List Items pane on the left side and the List Hierarchy pane on the right.

Show Status Bar shows or hides the status bar on the bottom of your screen, which tells you how many items are on the list and how many have been checked and flagged. To control whether you want indented items included in the number of checked items, flagged items and total items that is displayed in the status bar, use the List Properties Window.

Show Notes Pane shows or hides the Notes Pane at the bottom of the screen. This pane shows the Notes column for the currently selected item. Note that the contents of the Notes column is always shown in this pane, even if it is not selected in the Columns tab of the List Properties window. You can also edit the Notes column directly in this pane.

Show List Note shows or hides the List Note Pane below the tree of lists. This pane shows the List Note for the currently selected list. You can edit the List Note directly in this pane.

Hide Unflagged Items builds a new view of the list (such as for Two-Step or Shopping Lists) containing only those items you've flagged on your list. This is useful for flagging certain items that you need, or that are ready to do, and then displaying only those you need to act on. When this function is in effect, the Flag column does not appear in the display (if you have chosen that option in the Preferences window). There is also a button on the tool bar for this function.

Hide Checked Items will hide all items you've checked in your list. This gives you a clearer picture of which items are still left to be done. This function does leave the Checkbox column in the list displayed so you can continue to check items. When items are checked in this mode the item is immediately hidden from view once it is checked. There is also a button on the tool bar for this function.

Child and parent items in hierarchies follow special rules when these filtering functions are chosen.

Sort By displays the Sorting Window, which allows you to pick the column or columns to sort by. You can pick up to three columns to sort by, and you can sort by each column in ascending or descending order. When selecting a column, you can always pick item Number, even if the item numbers aren't showing, to put the list in its unsorted original order. If item numbers are showing, you can pick Item (or whatever name the Item column has, if it has been renamed) to sort alphabetically by the Item column. This is useful since clicking the Item column header when item numbers are showing will sort the list by item number. Picking any other column name to sort by that column is the same as clicking on the column's header. There is also a button on the tool bar for this function.

Note that when you sort a list, an item's child items will follow their parent item to its new position in the list. Therefore, it may look like items are out of order if you look only at the column you've sorted by. These child items will be sorted within the correctly positioned parent item.

The Ordered List submenu provides two functions that work only in Ordered Lists that are sorted. Remove Sorting will remove any sorting that you've done by clicking any of the list's column headers or by using the Sorting Window. If the Show item number option is being used, the numbers will be in order when sorting is removed. Also, if the list is temporarily sorted, you must use this option before you can move (reposition) list items. Reorder List changes the order of your Ordered List using the current sort order. This essentially make the temporary sort order permanent.

Filter opens the Filter Bar. The Filter Bar allows you to filter your list items by any column. Click in the Filter Bar above the column to filter by that column. This menu item changes to Remove Filter when the Filter Bar is showing, and choosing it hides the Filter Bar and removes filtering. There is also a button on the tool bar for this function.

Note that when you filter a list, a parent item will be displayed if any of its child items match the filter, even if the parent itself does not match. In addition, if a parent item matches the filter, all of its child items will be displayed, regardless of whether they match the filter or not. Therefore, you may see items in a filtered list that do not themselves match the filter criteria. These items will be displayed in gray text.

Clear Filters will clear any filters that you applied using the Filter Bar.

Items Menu

The Items menu also contains these functions to help you use your list items.

Delete Checked Items will delete all the items in the list that currently have the predefined Checkbox column checked. If you are using the list as a To Do list, this is an easy way to get rid of all the items you have checked as complete.

Check Selected Items will check the Checkbox column for all items that are currently selected.

Uncheck Selected Items will uncheck the Checkbox column for all items that are currently selected.

Tools Menu

The Tools menu provides these functions to help you customize and use your lists:

The Find menu item on the Tools menu will open the Find window, which allows you to enter a string to search for.

When you enter a string and push the Find Next button, the next item which contains the search string in any column will be selected. (Except as described below, the item will be selected only once, even if it contains more than one copy of the search string.) The list will scroll to the selected item, if necessary. You can leave the Find window open while you do other things with the list, if you wish.

If you press the Find All button, ListPro will show you a list of all the items found, rather than just one at a time.

If the Notes Pane is currently being displayed, individual matches within the Notes column will be highlighted there. If not, the item with the note will be highlighted to show one match, even if the value you're searching for appears more than once in the note.

If you check the Search all lists box, ListPro will search all lists in the file for a match, otherwise it will search only the currently open list.

If you choose Show only filtered matches, only items that match a list's current filter will be found.

If you choose Remove filters first, any matches found in items that are not currently being displayed will cause the current filter to be removed when the search begins. If no matches are found in a list, the filter will be replaced (left on).

When searching for a date, be sure to enter the date in the same format ListPro is displaying dates.

You can also active the Find and Find again functions using buttons on the tool bar.

Display Totals will show the total of the values in the Amounts column or any Number column you have added. You will be able to display subtotals by the predefined Units column, the predefined Category column or any Category column you have added. You can choose to total all items, or only flagged or checked items. There is also a button on the tool bar for this function.

Flatten Outline will remove all indentation from indented items in the list. This allows you to sort child items independently of their parent items. Information about each item's parent is stored in a new Parent column. Choosing the Unflatten Outline menu item uses this information to restore the indentation of each item.

Item Context Menu

When you right-click on a list item, you'll see the item context menu. This menu provides functions that operate on the selected items.

Copy to List will copy all currently selected items to an existing list. A window will open to allow you to pick the list to copy the items into. This functions just as if you had copied the selected items to the clipboard, opened another list and pasted the items into the list. Note that the items will be added at the end of the list. This function works best if the columns of the two lists are similar, because if a column is not the same type as the corresponding column in the other list, the data in that column will be lost.

Move to List is just like Copy to List except that the items are deleted from the current list after they are copied to the other list.

Autofilter will automatically filter the list using the value of the current column of the currently selected item (the current column will be the column that you clicked in). Only those items which have the same value as the selected item in that column will be displayed. The Filter Bar will automatically be shown if it is not already showing.

List Context Menu

When you right-click on a list in the list tree pane, you'll see the list context menu. This menu provides functions that operate on the selected list.

Export to ListPro File will copy the selected list to another ListPro file. This is particularly useful when you have opened a ListPro file attached to an email and would like to save a list inside in another file.

Send via Email will copy the selected list into a new ListPro file and attach the file to an email message. Your default email program will be opened in compose mode with the new message.

Open in New Window will create another ListPro window for the current file with the selected list open. This allows you to work on two different lists in the same file without having to switch back and forth between them.