Simple Software for a Simple Life!
Simple Software for a Simple Life!
INFO: Tips for Using ListPro on Windows PC
Views: 5395 Created: 08-11-2010 00:03 Last Updated: 08-31-2011 10:26

Use ListPro for any kind of list: instructions, tasks, shopping. It's especially useful for steps in a process you do frequently, but that doesn't recur at regular intervals, for example, releasing a new product. Special features for shopping lists create another very useful way to use ListPro. Ordered lists combined with Notes give you a way to record detailed instructions. Resetting your list lets you easily use lists over and over. Categories and Notes let you group items in many ways.

Use ListPro as a powerful, multi-level Notes organizer. Use the item column as your note titles, and put your notes into the Notes column for each item. Then organize the notes into lists, folders and list files, just the way you want them.

Use ListPro as an outliner by turning on the Show item number option (in List Properties) and dragging items to the right to indent them.

You can easily move lists between files using the Clipboard. Just select a list in one file, copy it, and paste it into another file. You can have ListPro running more than once to make this even easier. You can also use the clipboard to move items between lists. You can also copy lists from another file using Import Lists on the Tools menu.

You can sort the items in your lists by any column, just by clicking the column header.

Use the Notes Pane to see and edit longer notes or add information to items. You don't need to have the Note column selected for display in the list; the Notes pane will show this information for the selected list item.

To quickly enter information into lists, display only the columns for which you'll be entering information. You can always choose to show other columns later, but they'll be out of the way while you're doing data entry.

To easily copy or paste just the information you want, hide some columns using the List Properties window, use your clipboard to copy the remaining information, then show the columns again. To make it even easier, first move all columns that you want to copy to a position ahead of the ones that are turned off.

You can use the column header context menu to do all your column rearranging. Right click on the column header above a column to see the context menu, then pick Hide Column to hide the column or pick Show Column to show a column after the current one. Drag a column header to the right or left to order the columns.

Use the user-defined Yes/No columns to make your to-do list into a useful table. For example, if you need to do a multi-step cleanup on several different computers, you can make each step a list item and each computer a flag column. Then you can easily mark each step as it's complete for each machine. This is also useful for releasing several products, testing on several platforms, etc.

Note that category values do not have to be just one word. For example, if you have a list of items you need to pick up, and are using Category for where to get them, you might be able to get batteries at either a drugstore or a hardware store. You could make an additional Category column, or just put drugs, hardware in your main Category column. Then, if you Filter your list by either drugs or hardware, batteries will appear.

Make your lists more readable by changing the fonts in each column.

Choose Hide Checked Items (or its button on the tool bar) to hide items you've checked, if you only want to see what you still need to do.

Check Ilium Software's website for new sample and useful lists. You can use the Import List Wizard to easily import these lists into your ListPro file (choose Import Lists from the Tools menu).

A simple way to make it easy to tell which items in a list have been completed is to set a different color for checked items. Open the List Properties window and go to the Color tab. Press the Change button next to Color for Checked Items and choose a new color. Setting checked items to a gray color is a good choice because it makes the completed items look like disabled choices.

Use the Make Backup menu item from the File menu to easily make a backup of the current ListPro file. It's a good idea to do this regularly, especially if you're using File Synchronization to synchronize with a mobile device. You never know when you might want to retrieve something you deleted accidentally.

To start ListPro with a specific file open, double-click on the file in Windows Explorer.

New lists that you create can have the columns, fonts and settings you'd like -- and to make the choices automatically available every time, just make the appropriate changes to the lists in the Templates file.

Highlight your most important items in Item View or by right-clicking on a list item.

You can directly manipulate lists simply by dragging items, column headers and list names.

Preferences

On the Windows PC or Pocket PC, use Tools / Preferences to change the following list of behaviors.

  • Enable alarms for this file on this device: check to enable alarms for this ListPro file

  • Confirm deleting list items: check to see a confirmation dialog box when you delete a list item

  • Confirm deleting lists and folders: check to see a confirmation dialog box when you delete entire lists or folders

  • Confirm resetting lists: check to see a confirmation dialog box when you reset a list

  • Prompt on moving items in Ordered List: check to see a dialog box with options when you try to move items in a sorted, ordered list.

  • Confirm clearing columns: check to see a confirmation dialog box when you clear an entire column

  • Confirm remove filter on adding items: check to see a confirmation dialog box when you have a filter in place and attempt to add new items

  • Hide flag column on hide unflagged items: check to have the flag column disappear when you select View → Hide Unflagged Items, or when you click the flag button