Simple Software for a Simple Life!
Simple Software for a Simple Life!
HOWTO: Getting Started with ListPro on Windows PC
Views: 6421 Created: 08-10-2010 23:05 Last Updated: 08-31-2011 10:22

ListPro lets you create list files containing as many lists as you want. In turn, each list can contain thousands of list items. In addition, you can organize your lists into folders. Each list in any file can have a different set of columns appropriate to that list.

To create a list, open a Portal or ListPro file and select New List under the File menu (or use the New List button on the tool bar). To create a folder, open a Portal or ListPro file and select New Folder under the File menu. By creating folders you can group related lists together. You can create any number of lists in any ListPro file, and create any number of ListPro files. Use the New File menu item to create new ListPro files. Organize your lists into files in ways that make sense to you. Lists in the same file do not have to have the same sets of columns.

When creating new lists in a Portal, the Portal will create a blank list with columns appropriate for that portal. For instance, creating a new list in the To Do portal will provide you with a blank list perfectly formatted for creating a To Do list.

When you create a list in a Custom list file, select a template, choose which columns you want to be displayed, and give your new list a name. You can change the list's properties at any time by selecting the list and picking Properties from the Edit menu (or use the Properties button or double-click the list's name).

You can rearrange your lists and folders by dragging them to a new position. To place a list or folder into another folder, drag it beneath an open folder.

You can change which columns are displayed in your lists at any time, without losing the information in the columns not displayed. In the Columns tab of the List Properties window for the list, remove the X from the box next to the column name, and that column will no longer be displayed. Unless you specifically delete the column, all the data in the column will be retained even when not shown.

You will always be able to see the Note column for a list item in the Notes Pane or by double-clicking the item, even if you’ve chosen not to display the actual Notes column in your list.

Once you’ve created a list, select Add Items to List or Insert New Item from the Items menu (or use the Add Items button or the Insert Item button on the tool bar) to add items to the list.

You can export your list to another file, or import text from a file into ListPro.

To sort a list, click the column header of the column you want to sort by. To reverse the sort order, click the column header a second time. To change the order of the items on the list without sorting, use the arrow buttons in the command bar or select one of the Move Item menu items from the Items menu. (Note that you may not be able to move an item if the list is an Ordered List.) You can also move list items with cut and paste or by dragging and dropping selected items.

To filter a list, select Filter from the View menu and the Filter Bar will be displayed (or use the Filter button on the tool bar). Click on the filter bar above the column you want to filter and enter the value you want to filter on.

To check an item in a list, click its Check icon. To flag an item, click its Flag icon. If you want, you can set up your list to prompt you for amount value when you check or flag an item.

When you've completed a list, clear all the checks by selecting Reset List from the Items menu (or use the Reset button on the tool bar). All Checkboxes will be cleared from any items that have been checked. You can choose whether Flags and Amounts are also cleared on reset using List Properties.