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Chapter 1. ListPro Overview

1.1. Welcome to ListPro!

ListPro® is Ilium Software’s full-featured list maker. With ListPro, you can create and
maintain any kind of list you can think of. From to-do lists and shopping lists, to checklists
and outlines, ListPro makes list making fast and easy.

ListPro is both powerful and flexible, providing you with all the tools you need to build rich,
easy-to-use lists. Create the exact list you need using ListPro’s many features. In this document
you’ll find information about features like:

• Powerful Column Types – Dates, Rich Notes, Yes/No, Category, Linked, and 3-way
columns

• Complete column customization including fonts and formatting

• Alarms – ListPro can now tell you when a list item is due

• Reusable lists – build lists you can use, reset, and use again

• Color Highlighting

• Easy item manipulation with find, sort, flatten and filter

• Indented items and categories for powerful organization

• Add pictures in the notes to make rich and useful lists

• Customizable templates for easy list creation

• Hundreds of downloadable free lists available from Ilium Software’s website

• Special features for shopping and to-do lists

• Drag and drop list items and whole lists

• Autodate and calculated columns

• Synchronize, print, export and import your lists

• Total your columns and items

• Printing, list publishing, and export gives complete flexibility

There are endless ways to use ListPro. Here are some you might want to try:
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• Daily Tasks
• Project Steps
• Interview Questions
• Things To Pack
• Auction Tracking
• Project Planning
• Collectibles
• Errands
• Favorite Restaurants
• Customized To-Do Lists
• Gift Lists And Ideas
• Event Planning
• Web Sites To Check Out
• Software Unlock Codes
• CD And DVD Databases
• Videos To Rent
• Shopping Lists

You can combine any of ListPro’s columns and features to make exactly the list you want.
But you don’t have to start from scratch! We offer a set of pre-defined columns to help you
get started. These columsn include:

• Check Box
• Flag Item
• Priority
• Amount
• Units
• Item
• Category
• Date
• Notes

Learn more about columns here: Section 2.3, “List Columns” (page 32).

See Section 1.4, “Getting Started with ListPro” (page 7) to get started creating your lists!

1.2. Supported Platforms
ListPro is supported on the following Windows platforms:

• Windows® PC running Windows 7, Vista, or XP.

• Apple® iPhone® and iPod® touch, 3.0 and higher.

• Windows Mobile® 6 and Windows Mobile 6.1 and 6.5 Classic, Standard (non-touch) and
Professional (touch). Windows Mobile 6.5 devices are also known as Windows phones.
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• Windows Mobile 5.0 Pocket PC (touch)

• Windows Mobile 5.0 Smartphone (non-touch)

1.3. What's New in ListPro 5.0?
Here’s what is new in ListPro 5.0:

• Rich Text Notes (page 46) – Give your notes character with formating options. Choose
the font, size, and formatting for your information!

• Linked Images (page 47) – Add pictures to the notes pane. Great for collections, contact
lists, and more!

• RSS/XML Export (page 47) – Turn your favorite lists into news feeds using the new
RSS/XML export option!

• HTML Export (page 47) – Share lists with friends or post them to your website using
the HTML export option!

• Live Links (page 46) – Get quick access to web sites with the ability to add live web
links to your notes!

• Publish Lists (page 48) – It’s easy to get lists out to your mobile device with ListPro’s
one-click List Publishing! Instantly send lists and images to any Windows Mobile Pocket
PC (Professional) or Smartphone (Standard) device!

• ListPro Companion – Get answers to your most common questions with the easy to
use ListPro Companion, a set of step-by-step instructions for performing many of ListPro’s
most common tasks!

• Linked Files Location (page 45) – Easily link images, documents, or files of any type
to your list and publish them to your mobile device using the new Linked Files Location!

• Fresh new look – We’ve given ListPro a fresh new look to celebrate the new release!

• All New Templates – It’s easier than ever to build the list you want with an improved
set of built-in list templates!

• Live Numbers and Links for Palm – New for Palm OS, live web links, email, and
phone numbers with the Linked Field!

Here’s what was new in ListPro 4.1:

• Windows Mobile 5.0 - ListPro now fully supports Windows Mobile 5.0 Pocket PC and
Smartphone devices.

3

Chapter 1. ListPro Overview



• PalmOSEnhancements - The Palm OS version now also includes support for the Treo
5-way navigation button.

• Quick List (page 8) - You can now create a simple checklist with one click.

• Constants (page 12) - ListPro now allows for adding pre-defined constants to any calcu-
lated field.

• Find All (page 30) - ListPro’s Find All function creates a list of items that contain your
search criteria allowing you to quickly find and select the information you need.

• List Format (page 38) - We’ve made it much easier to change the appearance of a list.

• Item Format (page 9) - Strike-through is now an option for checked items.

• Wide Printing (page 57) - ListPro now prints on multiple pages if lists are wider than the
printer page.

• List Exchange1 Feed - The ListPro List Exchange now has an RSS feed so you can be
notified when new lists are available.

Here’s what was new in ListPro 4.0:

• Filter Bar (page 20) - You can now filter on any column.

• List Flattening (page 38) - You can change an outline into a flat list and back again.

• Drag to Indent - Indent an item by dragging it to the right or left.

• Export To List (page 54) - Choose the items and columns you want to use to create a
new list.

• Move/Copy to List (page 54) - Send items to an existing list (faster than cut and paste).

• Email Lists - Automatically send a list as an attachment to an email.

• Easier Column (page 11) Management - Columns are easier to create, arrange, hide and
show.

• List Note - A note field for each list to give you a place for information that applies to
the whole list.

• New List Wizard - Simplifies setting up a new list quickly.

• Clear Column - Quickly clears all entries in a column.

1 http://www.iliumsoft.com/listx
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• Change Column Type - A Number column can be changed to String, or a String to Cat-
egory.

• New 3-State Icon - A new stop-light style icon (reg, green and yellow circles) has been
added.

• Palm Enhancements - The Palm OS version now also includes support for FontBucket.

Many functions from ListPro 3.0 have been enhanced, but a few have been changed to
work differently. The following functions no longer work the way they did in 3.0:

• Blank values are now sorted to the end rather than the beginning when sorting items in
ascending order.

• Indented items are now copied to the clipboard slightly differently. The Item field now
contains a leading tab character for each level of indentation. See Section 4.2, “Using the
Clipboard” (page 50).

Here’s what was new in ListPro 3.0:

• Alarms (page 21) – ListPro can now remind you when a list item is due.

• Templates (page 24) allow you to create lists already configured with the columns and
settings you need for specific tasks, and you can add list templates of your own.

• Item View (page 16) – a new item view makes viewing and editing your list items more
convenient.

• New Column Type – Three State columns (page 36) are like Yes/No columns, but have
a third state.

• New Column Type – Linked columns (page 36) can link to a file or URL.

• You can now rearrange the lists and folders to put them in any order you want.

• ListPro now remembers the last list you were in and which folders were open.

• Category Values List – you can now edit the list of category values used in your category
columns.

• Date Columns can now be Time Only and Date/Time as well as Date Only. And an
Autodate feature allows the date to be updated whenever the item is changed.

• Date and Number columns can now contain simple calculations based on other columns

• Yes/No column icons can be changed.

• Undo – you can undo your last change.
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• Lists can now be reordered automatically after sorting, allowing items to be rearranged
after sorting.

• Items can now be rearranged even when the list is filtered.

• Items can be highlighted using one of four colors.

• Hierarchical lists (page 17) will now automatically keep child items with their parents
when indenting, moving, cutting, pasting and deleting items. And parents can reflect the
check boxes of their children.

• Expand All / Collapse All, Expand Branch / Collapse Branch for hierarchical lists.

• Cutting and Pasting (page 50) has been simplified so the indent level information is not
required and Yes/No columns can be skipped.

• Import and Export (page 52) now allow specifying which columns to transfer, and .CSV
files are supported.

• Synchronization (page 55) Wizard – makes it easy for you to set up synchronization with
your mobile device.

• Date and time can now be included when printing (page 57) your lists.

• List information is now stored in a scrambled format rather than stored as transparent
text, so no one can see your list information simply by opening the file in a text editor.

Many functions from ListPro 2.0 have been enhanced, but a few have been changed to
work differently. The following functions no longer work the way they did in 2.0:

• Using the export, import, and the clipboard to transfer items. See Section 4.2, “Using the
Clipboard” (page 50) to find out how this works now.

• Filtering (page 29) Items. Previously, when a parent item matched a filter, all of its child
items were displayed whether they matched or not. Now child items are only displayed if
they match the filter.

• Moving, indenting, cutting and deleting parent (page 17) items will now move all child
items as well. Previously parent items could be moved without affecting their
child (page 17) items. You can also now select whether check status is inherited between
parent and child items.

• You can now select whether lists are automatically reordered after each sort.
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1.4. Getting Started with ListPro
ListPro lets you create list files containing as many lists as you want. In turn, each list can
contain thousands of list items. In addition, you can organize your lists into folders. Each
list in any file can have a different set of columns appropriate to that list.

To create a list (page 8), select New List under the File menu (or use the New List button
on the tool bar). To create a folder, select New Folder under the File menu. By creating

folders you can group related lists together. You can create any number of lists in any ListPro
file, and create any number of ListPro files. Use the New File menu item to create new
ListPro files. Organize your lists into files in ways that make sense to you. Lists in the same
file do not have to have the same sets of columns.

Give your new list a name and choose which columns you want to be displayed. You can
change the list’s properties at any time by selecting the list and picking Properties from the
Edit menu (or use the Properties button or double-click the list’s name).

You can rearrange your lists and folders by dragging them to a new position. To place a list
or folder into another folder, drag it beneath an open folder.

You can change which columns are displayed in your lists at any time, without losing the
information in the columns not displayed. In the Columns tab of the List Properties (page 8)
window for the list remove the X from the box next to the column name and that column
will no longer be displayed. Unless you specifically delete the column, all the data in the
column will be retained even when not shown. See Section 2.3, “List Columns” (page 32).

You will always be able to see the Note column for a list item in the Notes Pane or by double-
clicking the item, even if you’ve chosen not to display the actual Notes column in your list.

Once you’ve created a list, select Add Items to List or Insert New Item from the Items
menu (or use the Add Items button or the Insert Item button on the tool bar) to add
items to the list.

You can export (page 52) your list to another file, or import (page 52) text from a file into
ListPro.

To sort a list, click the column header of the column you want to sort by. To reverse the
sort order, click the column header a second time. To change the order of the items on the
list without sorting, use the arrow buttons in the command bar or select one of the
Move Item menu items from the Items menu. (Note you may not be able to move an item
if the list is sorted. See Section 1.8, “Editing List Items” (page 14) for more information.)
You can also move list items with cut and paste or by dragging and dropping selected items.

To filter a list, select Filter from the View menu and the Filter Bar will be displayed (or use
the Filter button on the tool bar). Click on the filter bar above the column you want to
filter and enter the value you want to filter on.
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To check an item in a list, click its Check icon. To flag an item, click its Flag icon. If you
want, you can set up your list to prompt you for an amount (page 34) value when you check
or flag an item.

When you’ve completed a list, clear all the checks by selecting Reset List from the Items
menu (or use the Reset button on the tool bar). All Checkboxes will be cleared from any
items that have been checked. You can choose whether Flags and Amounts are also cleared
on reset using List Properties (page 8).

See Section 2.3, “List Columns” (page 32) to see how to choose just which columns you
want on your list, and Section 2.2, “Working with Lists” (page 28) to see how to customize
your list views.

1.5. Creating and Editing Lists
Create a list with the New List menu item on the File menu. The New List Wizard will let
you choose the type of list you want to create from the list of Templates (page 24). Then
choose the columns you want and enter a name for your list.

You can use the Quick List feature by using the New List button . Pressing this button
will instantly create a simple checklist with only a checkbox and an item column.

Once you’ve created your list, you can edit it at any time by double-clicking its name, or
choosing the Properties menu item or button . The List Properties window will open to
let you edit your list.

Set up the columns you want to use with this list on the Columns Tab:

• The Columns tab allows you to choose which columns will be displayed on the screen
for this list. See Section 2.3, “List Columns” (page 32) to see how to use these columns.
Note that information will remain in a column for any list even if it’s not displayed, though
it will be deleted if you explicitly delete the column. You can hide any columns in a list
without losing any information in that column.

• Check the check box next to each column you would like to be displayed. Columns that
are not checked will not appear in the list.

• Use the Add button to add a completely new column. You’ll see a popup menu that will
let you choose the type of column to add, and the column will be created with a default
name (which you can change). See Section 2.3, “List Columns” (page 32) for information
about how to add columns and what types of columns are available.

• Use theDelete button to delete an existing column. Note that you can only delete columns
that you’ve added. The default columns (those with an asterisk next to them: Checkbox,
Flag, Priority, Amount, Units, Item, Category, Date, Notes) can’t be deleted.
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• Use the Modify button to rename a column or change its properties.

• Select a column name and use the Move Up and Move Down buttons to change a
column’s position in the list. The order the columns appear in this list determines the order
they will appear when the list is displayed. Once you’ve created the list, you can also re-
arrange the list’s columns by dragging a column header to a new position in the List Items
pane.

Make sure you check the Flag column’s check box if you want to use the list as a Two-Step,
or Shopping List (page 37). When you do this, the Flag column appears in the list. You can
flag items in this column, then choose the Flag Tool to show a list containing only those
flagged items.

• Enter basic configuration information for the list on the Settings Tab:

• Check Show item number if you want the items in the list to be numbered. The item
number will appear in the Item column.

• Check Show alert on list completion to display an alert window when you’ve completed
all items on the list. This window will also allow you to reset the list.

• Check Status count includes subitems if you want indented items to be included in the
tabulation of the number checked items, flagged items and totals items that is displayed
in the status bar.

• Check Auto-check parent items to cause a parent item (page 17) to be checked auto-
matically when all of its children have been checked. If a child then becomes unchecked,
the parent is then unchecked also.

• Check Ordered List to retain the list item order when you sort. If this is not checked the
list item order will be changed to the new sorted order when you sort. If you check this
item, sorting the list will cause the items to be temporarily displayed in sorted order, but
the original order of the items will be remembered. You may want to turn this setting on
if you’ve checked Show Item Number or if the original item order is important to you.

• Check Strikeout checked items to show checked items with a line through them when
they have been completed.

Configure the actions taken when this list is reset using the Reset Tab:

• Check Flags if the Flag column should be cleared when the list is reset.

• Check Yes/No columns if you want all the Yes/No columns you added to be cleared
when you reset the list.

• Check 3-State columns if you want all the 3-State columns you added to be cleared when
you reset the list.
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• Check Amounts if you want the Amounts (Amt) column to be cleared when you reset
the list.

• Check Highlight if you want the Highlight color (page 17) to be cleared when you reset
the list.

• Select Reset all items if the columns checked above should be cleared in all items when
you reset the list.

• Select Reset only checked items if the columns checked above should only be cleared
in items where the predefined Checkbox column is checked.

Set up special colors for displaying items on the Format tab:

• The Color For Checked items text box shows the color for an item that has been
Checked. You can use the Change button to change this color.

• TheColor For Flagged items text box shows the color for an item that has been Flagged
but not Checked. Use the Change button to change this color.

• The Font text box shows the default font set for the list. Use the Change button to
change the font.

If both options are selected, items that are both checked and flagged will be the Checked
item color.

Set up reminders or alarms for this list on the Alarms Tab:

• The name of the column the alarms (page 21) will be based on is displayed at the top.
Alarms are always based on the predefined Date column, so the current name of this
column will be displayed (which may be something other than “Date” if you’ve renamed
it).

• Check Enable alarms for this list to turn on the alarms function for this list.

• Check Time of day to display alarms if your Date column is Date Only and you want
the alarm (page 21) to go off at a certain time of day. Enter the time of day to sound the
alarm in the following field. If you don’t check this option, alarms for Date Only columns
will go off at 8:00 AM. Note that this setting takes affect only if your Date column is Date
Only; with Date and Time columns the alarm will always go off at the time given in the
item.

In order for alarms (page 21) to work in your list, you must also enable alarms for the current
File. You can do this by choosing Preferences from the Tools menu and checking Enable
alarms for this file on this computer. Using alarms also requires that your predefined Date
column be configured as either Date Only or Date and Time. Alarms will not operate if the
Date column is Time Only.
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1.6. Creating and Editing Columns
Once you have created a list, you’re not stuck with the list of columns you start out with.
You can change the properties of the existing columns or create completely new ones.
Columns are created or modified using the Columns Tab of the List Properties window.
(To open the List Properties window for an existing list, select the list and either choose
Properties from the Edit menu or just double-click the list name). You can also hide, show
or modify columns by right-clicking on the column header to display the context menu and
then choosing Hide Column, Show Column or Column Properties.

You can create a new column by pushing the Add button. You’ll see a popup menu from
which you can choose the type of column you want to create. When you click one of the
choices, a column of that type will be created with default properties and a default name
(which you can edit).

You can edit an existing column’s properties by selecting the column and pushing the
Modify button, or just by double-clicking the column name. The window you see will depend
on the type of column.

All columns have a name property, so the Column Properties window will always include a
Name field. String and Linked columns have no other properties, so for these column types
there will be no other information to edit. In addition, the predefined Checkbox, Flag and
Priority columns do not allow editing any properties other than Name. Property information
for other column types is described below.

1.6.1. Category Columns

• The Column Properties dialog for Catagories allows you to change the font for the
column by pressing the Change button.

• Check Automatically add new category values if you want all new category values
entered into any item in the list to be added to the list of category values for that column.
If you want to build and maintain the list of Category Values manually, you can uncheck
this option to prevent new values from being added. To edit Category Values, use the
Category Values window by picking Category Values from the Tools menu.

1.6.2. Number Columns

• The Column Properties dialog for Numbers allows you to define a calculation and to
change the font for the column by pressing the appropriate change button.

• Choose the type of calculation for this column from the list. By default the calculation is
None, which allows you to enter numeric data into this column. Any other choice will
cause this column to display the result of the calculation and entering data into the column
will not be allowed. The other choices allow addition, subtraction, multiplication or division.
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• If you chose a calculation for this column, choose the columns that are represented by A
andB in the calculation. BothA andB provide a list of eligible Number and Date columns
that you may choose from. You may choose Date columns only if the calculation is sub-
traction, and the Date columns must have the same Form. The columns chosen for A
and B must either be both Numbers or both Dates. Columns that are already the result
of a calculation may not be chosen.

• You can use a constant in a calculated column simply by selecting <Constant> for A or
B. For example, to add the constant 5 to a number column called Amt, set A to Amt, set
B to <Constant> and type 5 into the Constant field.

1.6.3. Date Columns

• TheColumn Properties dialog for Dates allows you to define a calculation and to change
the font for the column by pressing the appropriate change button.

• Choose a Form for the column from the list. If you choose Date Only, only a date will
be displayed without a time. If you choose Date and Time, a date and time will be dis-
played. If you choose Time Only, only a time of day will be displayed without a date. All
forms may be used with date calculations, but onlyDate Only andDate and Time forms
may be used for alarms.

• Choose a Behavior for the column from the list. The default behavior is Manual, which
will allow you to enter information into the field. The Auto Date/Time behavior auto-
matically updates the column with the current Date/Time whenever the item is changed.
The behavior Calculate A + B will calculate the value of the column by adding a number
column to a date column. The behavior Calculate A – B will calculate the value of the
column by subtracting a number column from a date column. For example, you could
use Calculate A + B to add a task starting date (in a Date column) and the number of days
assigned to the task (in a Number column) to get the due date.

• You can use a constant in a calculated date column simply by selecting <Constant> for
A or B. For example, to add 5 days to a column called Date, set A to Date, set B to
<Constant> and type 5 into the Constant field.

• If you chose a calculation for this column, choose the columns that are represented by A
and B in the calculation. The choices for A are the eligible Date columns and the choices
for B are the eligible Number columns. Only Date columns with the same Form as this
column may be chosen for A. Columns that are already the result of a calculation may
not be chosen.

When choosing a calculation for the column, the way the Number column is interpreted
depends on the Form of the Date column. If the Date column is Date Only or Date and
Time, the Number column that is added or subtracted is interpreted as a number of days.
If the Date column is Time Only, the Number column is interpreted as a number of minutes.
Fractional days and minutes may be used. For example, 0.01 days is about 15 minutes.
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Please note that you won’t be able to edit the data in columns that are Autodate or calculated
columns, since the data for the column is determined by the change date or the calculation.

1.6.4. Yes/No Columns

• Select an icon style from the Icon style list to determine what icon will be displayed for
this column.

• Check Invisible when off if you don’t want any icon to be displayed at all when the value
of this column for an item is Off (unchecked). The normal icon will be displayed when
the value is On (checked).

1.6.5. Three State Columns

• Select an icon style from the Icon style list to determine what icon will be displayed for
this column.

1.7. Adding List Items
You can add items to your list using the Item View Window, or you can insert them directly
on your screen.

1.7.1. Item View Window

You’ll see the Item View window when you choose the Add Item to List menu item or
button . The Item View window allows you to enter information for one or more new list
items. See Section 1.9, “Using Item View” (page 16) for more information.

1.7.2. Inserting New Items Directly

You can insert a new item directly into the list by picking Insert New Item from the Items
menu or by using the Insert New Item button . The first field in the list will be opened for
direct editing, so you can immediately start typing the item information into the field. Use
the tab key to go to the remaining fields in the item and fill in their data.

If you use the tab key while direct editing the last field of the last item in your list, another
new item will be inserted following the item, and the first field will again be opened for direct
editing. You can use the tab key to enter data for fields and insert new items continuously
until you’ve entered all the new items you need.

1.7.3. Positioning List Items

Items will be added to your list following the currently selected item. If the list is an Ordered
List with a temporary sort applied (see Section 1.11, “Sorting Your Lists” (page 18)), items
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will still be added following the currently selected item, but they will be temporarily displayed
according to the current sort order.

You can use Remove Sorting on the Ordered List submenu of the View menu to remove
any temporary sorting. This will allow you to control the order of list items with the arrow
tools , theMoveUp andMoveDownmenu items or by dragging items to new positions.
You can also control the indent level of each item with the arrow tools , the Move Left
and Move Right menu items or by dragging items to the left or right.

If you’ve sorted an Ordered List and would like to make the sorted order permanent, you
can pick Reorder List from the Ordered List submenu of the View menu. If you do this,
you won’t be able to use Remove Sorting to return to the original order, but you can then
use the arrow tools and drag and drop to rearrange the items. If you haven’t checked the
Ordered List option in the Settings Tab of the List Properties window, the new sort order
will be made permanent automatically whenever you sort.

1.8. Editing List Items
You can edit the items on any of your lists at any time using either the Item View window,
or by editing them directly right on your screen.

1.8.1. Item View Window

Double-click any item in your list, or select any item and pick the Properties menu pick or
button to display the Item View window. Use this window to change any of the values
for your list items. See Section 1.9, “Using Item View” (page 16) for more information
about the Item View window.

1.8.2. Direct Editing

You can also edit any of your list items directly without using the Item View window. When
you click in any text, number or date column of a currently selected item, that column will
become editable. You can use the mouse or keyboard to edit the column or enter new text.
Category columns provide a drop down list of values to choose from, and date columns will
provide a calendar drop down. A Notes field containing multiple lines of text will expand
to provide a multiple-line editing area large enough to edit the whole field. You won’t be
able to edit columns that are Autodate or calculated columns, however. You’ll only be able
to edit Linked columns in item view, since in list view clicking on them activates them.

While you are direct editing a field, you can use the Enter key to close direct editing and save
your changes, or you can use the Escape key to discard your changes. You can also close
Direct Editing by clicking outside the field with the mouse. You can use the tab key to close
the current column and open the next column for Direct Editing (shift-tab opens the previous
column). If you are direct editing the last column in the last item in your list and you use the
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tab key, a new item is inserted into the list, and the first column of the new item is opened
for direct editing.

You can also start direct editing currently selected item by pressing the space bar. The last
column direct edited or the last column clicked on is opened for direct editing when you
press the space bar.

The left and right arrow keys can be used to change the focus to individual columns in an
item. When an item is first selected, the entire item will be enclosed by the focus rectangle
(a light, dotted outline of the item). The arrow keys will move the focus rectangle to individual
columns. The column that has the focus when you press the space bar will be opened for
direct editing. If a Checkbox or Flag column has the focus, you can use the space bar to
check or uncheck the column.

If you have selected Show Notes Pane from the View menu, you can also directly edit the
Notes field that is currently showing in the Notes Pane.

See also:

Section 2.7, “Using the Keyboard” (page 41)

1.8.3. Repositioning List Items

You can move list items up or down with the arrow buttons in the tool bar or the
Move Up and Move Down items in the Items menu. You can drag items to a new position
using the mouse. You can also use the clipboard Cut and Paste features to change the position
of list items. You can change the indent level of an item with the arrow buttons in the
tool bar or the Move Left and Move Right items in the Items menu. You can drag items
to new indent levels using the mouse.

List items can only be repositioned when no temporary sort has been applied (See Sec-
tion 1.11, “Sorting Your Lists” (page 18)). Use Remove Sorting on the Ordered List sub-
menu of the View menu to remove any temporary sorting or filtering and allow you to
change the order of list items. This applies only to Ordered Lists.

If the list is sorted and you’d like to automatically reposition all items using the current sort
order, select Reorder List from the Ordered List submenu of the View menu. You will not
be able to return to the original order by picking Remove Sorting, but you will be able to
reposition individual items. If you haven’t checked the Ordered List option in the Settings
Tab of the List Properties window, the new sort order will be made permanent automatically
whenever you sort.

Note that when you paste items into the list, they will be pasted following the currently se-
lected item. If the list has a temporary sort applied, pasted items will appear in the list in
their sorted position.
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1.9. Using Item View
The Item View window opens when you choose Add Items to List from the Items menu
(or use the Add Items button on the tool bar). You can also open the Item View window
by double-clicking an item, or by selecting an item and picking Properties from the edit
menu (or using the Properties button on the tool bar).

The Item View window displays a list of all the columns that are currently showing in your
list so you can enter new information for each column. In addition, an area for entering
Notes is always present at the bottom.

For most column types, simply click in a field or tab to it and enter the new information.

Category columns also provide a drop-down list so you can choose from the existing Cat-
egory Values if you like. Categories are not case-sensitive when using them to sort or filter:
Hardware is the same as HARDWARE or hardware.

EachCheckbox, Flag andYes/No column can be updated by clicking on its icon to toggle
its state. You can also tab to these fields and press the space bar to toggle the state.

Each Three State column can be updated by clicking on its icon to cycle through its three
states. You can also tab to the field and press the space bar to change the state.

Date columns provide a Date Picker control to allow setting their values. The checkbox at
the left end can be left unchecked to indicate no date/time should be displayed. For Date
Only and Date and Time columns, the button at the right end will display a Month View
window that allows you to pick a date rather than typing one in. For Time Only columns,
the Up/Down control at the right end allows you to adjust the time up or down by clicking
rather than typing in a new time.

Linked columns also provide a button that will display a window to allow you to choose a
file to link to. To enter a URL rather than a file name simply type in the URL or paste it into
the field from the clipboard. All URLs must begin with the proper prefix (http://, ftp://
or file://) in order to be recognized as a URL rather than a file name.

Please note that if a date or number column is configured to display a calculated value then
the current value will be displayed but you will not be able to enter in a value. This is because
the result of the calculation is always displayed. As you update other columns the calculated
columns will be updated to reflect the calculated value. Similarly, Date columns set to the
AutoDate/Time form cannot be updated directly, but will automatically update to the current
time when any other column is changed.

Remember that the Item View window only displays the columns you have configured to
show in your list. If you want to enter data into different columns, go to the Columns Tab
of the List Properties window to change which columns are showing.
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The Item View window also allows you to change an item’s highlight color and indent level:

• Highlight determines the color that will be displayed as the background color in the List
Items pane. Click on the Highlight control to drop down a list of highlighting colors and
choose the one you want.

• Indent Level determines whether the item should be indented and how much. An Indent
Level of zero means the item is not indented. Note that indenting an item gives it a par-
ent/child relationship to the item above it (see Section 1.10, “Working with Hierarch-
ies” (page 17)). To change the item’s indent level you can either type in a new indent level
value or use the < and > buttons to decrease and increase the indent level. Please note
that when you change the indent level of an item its child items will be adjusted by the
same amount.

When you’re done entering a new item’s information you can click OK to save the item and
exit the Item View window. If you click New Item instead, the item will be saved but the
Item View window will remain open and all fields will be cleared; this lets you enter another
new item. The Next and Previous buttons can be used to move to the next or previous
item in the list (as it is currently displayed). Any new information or changes you make will
automatically be saved when you push OK, New Item, Next or Previous. If you have
entered changes that have not been saved when you press the Close button, Item View will
ask if you want to save the changes.

Note that Item View only shows items that are not filtered (page 29).

Tips

Use Item View to quickly edit many list items. Alt-N and Alt-P let you easily
navigate between items.

You can resize the Item View window to give you more space to enter informa-
tion.

1.10. Working with Hierarchies
You can use indented items in your list to create a hierarchy of items. This hierarchy is shown
in the Item column of your list. That is, all indentation is shown in the Item column. Other
columns are not shown indented and the indentation level does not affect them.

You can increase or decrease the Indent Level of list items with the arrow buttons in
the tool bar or the Move Right and Move Left items in the Items menu. You can also
drag items left or right to change the indent level. As with moving list items up and down,
you can move items right or left in an Ordered List only when no temporary sort has been
applied.
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Increasing the Indent Level of an item gives it a parent/child relationship with the item
above it.

If an item has indented items below it, it’s name will be preceded by a minus (-) if the items
are showing or a plus (+) if they are not showing. You can click on the plus or minus to
expand or collapse the hierarchy, showing or hiding all indented items below the clicked
item. Note that the + and - signs appear only in the Item column.

All child items, those that are indented below a parent item, will automatically follow the
parent item wherever it goes. When you move, delete, cut, copy or paste an item, all the
child items that are indented below the item will be moved with it. This is true regardless of
whether the parent item’s hierarchy is expanded or collapsed, and regardless of whether all
the child items are showing or not. To separate the indented child items from their parent
item, move the child items out of the hierarchy rather than moving the parent.

To select an item and all items indented below it, click on the minus sign in front of the item
name and hold the mouse button down. This will show you explicitly all the items that are
affected when the parent item is moved.

When you sort a list, a parent item’s child items will follow their parent item to its new pos-
ition in the list. Within each hierarchy, child items at a given level with a common parent
will be sorted as well.

When you filter a list, a parent item will be displayed if any of its child items match the filter,
even if the parent itself does not match. In this case, the parent item will be displayed in gray
to indicate that it does not match the filter.

If you have chosen the option Auto-check parent items in the List Properties Settings
Tab, ListPro will try to keep the checkboxes consistent for parent and child items. That is,
if you check all the child items of a parent item, the parent item will be checked also. Further,
if you check a parent item, all its child items will be checked.

1.11. Sorting Your Lists
To sort a list by the values in a column, click on the column header. Clicking once sorts in
ascending order; clicking a second time sorts in descending order. If you edit an item in your
list after sorting, clicking the column header will reapply that sort again rather than switching
between ascending and descending orders.

1.11.1. Sorting Modes

Each list can be configured to operate in one of two modes when maintaining the order of
your list items. These two modes are controlled by the Ordered List option in the Settings
Tab of the List Properties window. These two modes operate as described below:
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1.11.2. Ordered List is Off

This is the default mode for new lists. When you sort your list, the items are rearranged into
the new sorted order and the previous order is lost. In this mode, the Remove Sorting
menu function is never available. This mode is useful for lists in which preserving the order
of items isn’t important.

1.11.3. Ordered List is On

In this mode, sorting your list doesn’t change the actual order of the items; instead, it causes
ListPro to display a sorted view of your list, temporarily. The items remain in their original
order, but they will be displayed in sorted order. If you want to make the sorted order per-
manent, you can select Reorder List from the Ordered List submenu of the View menu.
Or you can remove the temporary sorting by selecting Remove Sorting from the Ordered
List submenu of the View menu.

While a temporary sort is in effect, you can’t reposition the items by dragging them or using
the move buttons (if you try to reposition them, you’ll see an alert). New items added to the
list are automatically displayed in their sorted position.

In versions of ListPro prior to 3.0, this mode was always used.

See Appendix A, Ordered and Unordered Lists (page 59) for a more detailed explanation.

1.11.4. Choosing a Mode

If you want to see the temporary and permanent ordering more clearly, turn on the Show
item numbers option in the Settings Tab of the List Properties Window. This option causes
the Item column of each item to display its item number, which is just the numerical position
of the item in the list. If the list is not sorted, the item numbers will be in order. If you sort
the list using a temporary sort (Ordered List is on), the item numbers may no longer be in
order. If you make the sort permanent by picking Reorder List, you’ll see that the items
continue to be displayed in the same order, but the item numbers are now in order. If you
sort the list using a permanent sort (Ordered List is turned off), the item numbers always
remain in order even though the order of the items is changed by the sort.

In most cases you’ll probably want to leave Ordered List off. You may want to turn it on,
however, if the items in your list have an inherent order that you want to control. Examples
of this type of list might be a recipe where the steps must be done in a certain order or a
classic process checklist where the items are checked off in a specific order. Sorting may still
be useful with such lists because you may want to use it to temporarily group items by cat-
egory, to view items from highest to lowest by some column or to find a specific step in a
process by viewing the steps alphabetically.

Another consideration for very large lists is that turning Ordered List off may slow down
sorting noticeably because the items must be moved as well as sorted. In this case you can
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speed up the sorting by turning Ordered List on and manually reordering the list when
necessary by picking the Reorder List menu function.

1.11.5. Sorting by Multiple Columns

Often you want to sort your list by one column, but within items having the same value of
that column you’d like to sort by a different column. For example, if your list has Project
names as its Category values, you may want to sort by Category in order to group the items
by Project, but within each Project you’d like to sort the items by Priority.

To accomplish this, choose Sort By from the View menu or use the Sort By button on
the tool bar. You’ll see the Sort window, which will allow you to choose three columns to
sort by. For each column you can also choose whether to sort in ascending or descending
order. For the example above, you’d choose Category for the first column, Priority for the
second column and leave <None> for the third. You’d leave Ascending as the choice for
all of them.

1.12. Filtering Your Lists
You can filter your list by any column using the Filter Bar. To open the Filter Bar, choose
Filter from the View menu or use the Filter button on the tool bar. While the Filter Bar
is present, all the filters in the Filter Bar are applied to the list. If the Filter Bar is closed, no
filters are applied and you’ll see the entire list.

To filter by a certain column, click in the Filter Bar above that column. For Checkbox, Flag,
Priority, Yes/No, 3 State and Date columns, you’ll see a menu where you can choose the
value to filter by. Some of these menus will also have a More Options selection that will
display a window where you can enter a value. For Category columns you’ll see a drop down
list where you can choose the category value to filter by. For String and Numeric columns
a window will open where you can enter a value to filter by. Numeric and Date columns
also allow you to filter on column values related to the filter value with a relational operator
(equal to, not equal to, greater than, less than, greater than or equal and less than or equal).
On these columns, clicking on the relational operator in the Filter Bar will show a menu of
operators you can choose from.

For example, if you click in the Filter Bar above the Checkbox column, a menu will pop up
where you can choose <Off>, Checked (or Yes) or Unchecked (or No). If you choose
Checked, only items with the Checkbox checked will be displayed.

As another example, if you click in the Filter Bar above the Amt column (which is a Numeric
column), a window will display where you can enter a numeric value and choose an operator.
If you enter 50 as the value and greater than as the operator, only items with an Amt column
with a value greater than 50 will be displayed. If you then click on the greater than sign in the
Filter Bar, you’ll see a menu of operators and could choose a different one, such as greater
than or equal.
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When you have filters on multiple columns, an item must match all the filters in order to
be displayed.

Note that when you filter a list, a parent item will be displayed if any of its child items match
the filter, even if the parent itself does not match. In addition, if a parent item matches the
filter, all of its child items will be displayed, regardless of whether they match the filter or
not. Therefore, you may see items in a filtered list that do not themselves match the filter
criteria. These items will be displayed in gray text.

The special Checkbox and Flag filter functions (Hide Checked Items andHideUnflagged
Items on the View menu) can be used whether the Filter Bar is showing or not. Showing
or Hiding the Filter Bar will not affect these functions.

1.12.1. Changing the Operator

Once you have a filter value entered for a column, you can tap or click on the filter bar to
change it. You can also change the operator, for column types that use it. With date and
number filters, in particular, it’s useful to be able to quickly switch between an exact search
(“is equal to”) and, for example, “less than or equal to.”

1.12.2. Filtering On Hidden Items

If you turn the filter bar on (with View → Filter, and you see the following situation:

• All the filter bar column headings are empty

• Some of your items still seem to be filtered out

You may have a filter in place, on a hidden column. Remember that checking or unchecking a
column’s box in Edit → List Properties, doesn’t delete the column -- it just hides it. And
if you’ve applied a filter to a column, then you hide it, that filter is still in place, still filtering
out items.

If you think this is happening, turn the filter bar off (with View → Filter, and see if your
items are all being displayed. If so, you can do one of two things:

• Remove all filters with View → Remove Filter

• Go to Edit → List Properties and check unchecked columns until you identify the one
with an active filter

1.13. Using Alarms
ListPro allows you to set alarms based on the items in your lists. When the time for the alarm
arrives, ListPro will pop up a window on your computer. The alarm will be displayed regard-
less of whether ListPro is running or not.
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Alarms are always based on the predefined Date column in each list. If you enable Alarms
for a list, each item in the list that has a date entered into the Date column can cause an
alarm to go off when that date arrives. For example, if the item represents a task and the
Date column holds the Due Date, the alarm will go off on the date the task is due.

1.13.1. Setting up Alarms

Here’s how to set up an alarm for one of your lists:

1. Make sure alarms are enabled for your ListPro File. To do this select Preferences from
theToolsmenu and make sureEnable alarms for this file on this computer is checked.

2. Open the List Properties window for your list and select the Columns Tab. Find the
predefined Date column and make sure its checkbox is checked so you can use the column.
The predefined Date column will have an asterisk at the end of its entry in the type column
(“Date*”). It’s OK to rename this column to something other than “Date” if you want
to.

3. Select the Date column and push the Modify button to open the Column Properties
window for this column. Alarms will work if the column’s Form is set to Date only or
Date and time, but not Time only. If the Form is Date and time, the item’s current
value will determine both the date and the time of day that the alarm goes off. If the
Form is Date only, the current value will determine the date, but the time of day will
depend on the setting in the Alarms Tab (see step 4 below). Close Column Properties.

4. Select the Alarms Tab of the List Properties window. The name of the column that will
be used for Alarms is noted at the top, so make sure it is the column you plan to use.
Then make sure the Enable alarms for this list option is checked. If your Date column
is using the Form Date only, make sure to check Time of day to display alarms and
enter the time of day you want the alarms to go off. If you don’t enable this option the
alarm will go off by default at 8:00 AM. If your Date column is using the Form Date
and time, the Time of day to display alarms option is not used since the alarm will
activate at the time chosen for the item in the Date column.

5. Make sure that there is a value in the Date column for each item in your list that needs
an alarm.

When an alarm goes off, a window appears up on your computer to telling you the item
name, list name and file name for the alarm. If you push the Close button on the window,
it will simply go away. If you push the Open button, the list is opened (launching ListPro,
if necessary), with the alarm item selected.

1.13.2. Things to Keep in Mind

ListPro can keep track of the alarms in your ListPro files as long as it knows where they are.
When you first enable alarms for a list in a given file, ListPro will ask you to enable alarms
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for the file. If you move or rename your file, however, ListPro will no longer know where
it is. For this reason, anytime you move or rename a ListPro file with alarms in it you must
re-enable alarms for the file by selecting Preferences from the Tools menu and checking
the Enable alarms for this file on this computer option.

You must also manually enable alarms for a ListPro file in the following cases:

• You received a ListPro file via email.

• You downloaded a ListPro file.

• You created the ListPro file using ListPro on a Pocket PC or other mobile device and
then File Synced it to your Windows PC computer. When you enabled alarms for the file
on the mobile device, it was enabled on that computer, but not on your Windows PC
computer; you still have to enable alarms manually there..

• You are using a ListPro file that is on a File Server on your LAN, and it was created on
a computer other than your Windows PC. If the file on the File Server becomes inaccessible
for a long period of time, you may have to re-enable it again. Also, when a ListPro file is
shared on a LAN, alarms that were not set by you are not guaranteed to go off on your
computer. Most alarms set at least a day in the future will go off, however.

Of course, you can also disable alarms for certain ListPro files if you do not want to receive
alarms for them. For example, you may want to receive the alarms on your mobile device,
but not on your Windows PC.

1.13.3. Alarm Tips

Tips

The Date column you use for alarms is not required to use theManual Behavior.
The AutoDate/Time Behavior would not be useful, but you might want to use
Calculations. For example, if you have a list of meeting date/times you might
want an alarm to go off a short time before the meeting rather than right when
the meeting starts. You could accomplish this by having an additional date column
called Meeting Time that holds the actual meeting time and a Number column
called Warning Time that holds the amount of time before the meeting that you
want the alarm to go off. You then set the Date column for alarms to be a calcu-
lation of Meeting Time minus Warning Time. The alarm will then go off a short
time before the meeting. The Date column would not have to be showing in the
list in this case. One thing to be aware of is that Warning Time is interpreted as a
number of days, so you would enter 0.01 for a 15 minute warning, 0.02 for a half
hour warning, and so on.
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You may have noticed that ListPro installs a program called ListProAlarms in
your Startup menu. This program is required to be running in order for ListPro
to display alarms. This program uses few resources, so it should not be noticeable
even if you’re not using alarms. If you wish to remove this program from your
Startup menu so it’s not always running, doing so will not effect the normal op-
eration of ListPro, except that alarms will never go off.

Alarms are only accurate to about a minute, so they will not necessarily go off
the moment your computer’s clock reaches the appointed time. They should go
off within a minute of that time, however.

1.14. List Templates
When you create a new list, the New List Wizard allows you to choose the type of list from
a set of Templates. Each template is configured with appropriate columns, category values,
settings and fonts for a certain type of list. The Basic Checklist template contains just
Checkbox and Item columns. The names of the other templates describe the type of list
they can be used to create.

The list of templates is a hierarchical list, so if you see a “+” in front of a name in the list,
it is really a folder of templates, and you can click on the “+” to open the folder and see the
templates inside. Folders organize the templates into groups so you don’t have to scroll
through a large list to find the template you want.

One of the best things about templates is that they are just ListPro lists, so you can add new
ones and change the existing ones if you want. To edit the templates, just useEdit Templates
on the Tools menu. Each folder in the Templates file shows up as a folder in the templates
list, so you can rearrange the lists and folders in the Templates file to change how the tem-
plates appear when you create a new list.

Here are some things you can change about the templates to personalize your list-making:

• If you prefer a different list font from the default used by ListPro, set the default list font
in all the templates to your favorite font.

• If you always want your new lists to start with a certain set of columns, change one of the
lists (or add a new list) to have those columns.

• You can edit the Category Values list for a category column so the lists will always start
out with those category values in the drop down list.

• You can fill the template with an initial set of items and these items will always be present
in the new lists when they are created. If you constantly have to go through the same
checklist but want to keep your old checklists rather than resetting them, this would allow
you to do that easily.
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• You can set up an initial sort order so items will show up in that order.

• You can order the lists in the Templates file and put them in folders.

If you have a Pocket PC, ListPro templates are stored in the file Templates.clf in your
synchronized files folder, in My Documents\Templates. Note that this is a change
from previous versions of ListPro; the templates used to be stored in the product’s installation
folder. Since the templates file is in your synchronized files folder, it will be synchronized
between your Pocket PC and Windows PC. If you don’t want to have templates synchronized,
you can move the templates file somewhere else, outside the synchronized files folder. If
your templates file is not already in the synchronized files folder and you’d like to have it
synchronized with your Pocket PC, you can move it into the Templates folder of your
synchronized files folder. Any time you move the templates file, you must tell ListPro where
it is by using the Choose Templates File menu item on the Tools menu.

If you invent any particularly useful templates, we encourage you to send them to the ListPro
List Exchange2 on our website so we can share them with other ListPro users.

2 http://www.iliumsoft.com/listx
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Chapter 2. Using ListPro

2.1. Launch Window
The ListPro Launch Window gives you easy access to your portal lists, synchronized list
files, and any customized lists you may have.

2.1.1. ListPro Portals

The Portals area of the Launch Window gives you quick access to three pre-configured
listypes: To Do, Shopping and Checklists.

27



2.1.2. Recently Used Files

This area of the Custom List Collections provides an easy way to get to ListPro list files that
you've recently opened.

2.1.3. Synchronized Files

This area of the Custom List Collections provides access to your ListPro list files that are
synchronized with an iPhone or iPod touch.

2.2. Working with Lists
You can use the selections on ListPro’s edit, View, Items, and Tools menus to customize
your lists’ appearance and functionality.

See also:

Section 2.3, “List Columns” (page 32)

2.2.1. View Menu

ListPro’s View settings allow you to select just how you want to see your list.

List on Left puts the List Items pane on the left side and the List Hierarchy pane on the
right.

Show Status Bar shows or hides the status bar on the bottom of your screen, which tells
you how many items are on the list and how many have been checked and flagged. To control
whether you want indented items included in the number of checked items, flagged items
and total items that is displayed in the status bar, use the List Properties Window (page 8).

Show Notes Pane shows or hides the Notes Pane at the bottom of the screen. This pane
shows the Notes column for the currently selected item. Note that the contents of the Notes
column is always shown in this pane, even if it is not selected in the Columns tab of the List
Properties window. You can also edit the Notes column directly in this pane.

Show List Note shows or hides the List Note Pane below the tree of lists. This pane shows
the List Note for the currently selected list. You can edit the List Note directly in this pane.

Hide Unflagged Items builds a new view of the list (such as for Two-Step or Shopping
Lists (page 37)) containing only those items you’ve flagged on your list. This is useful for
flagging certain items that you need, or that are ready to do, and then displaying only those
you need to act on. When this function is in effect, the Flag column does not appear in the
display (if you have chosen that option in the Preferences window). There is also a button

on the tool bar for this function.
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Hide Checked Items will hide all items you’ve checked in your list. This gives you a clearer
picture of which items are still left to be done. This function does leave the Checkbox column
in the list displayed so you can continue to check items. When items are checked in this
mode the item is immediately hidden from view once it is checked. There is also a button

on the tool bar for this function.

Child and parent items in hierarchies follow special rules when these filtering functions are
chosen. For more information see Section 1.10, “Working with Hierarchies” (page 17).

Sort By displays the Sorting Window, which allows you to pick the column or columns to
sort by. You can pick up to three columns to sort by, and you can sort by each column in
ascending or descending order. When selecting a column, you can always pick itemNumber,
even if the item numbers aren’t showing, to put the list in its unsorted original order. If item
numbers are showing, you can pick Item (or whatever name the Item column has, if it has
been renamed) to sort alphabetically by the Item column. This is useful since clicking the
Item column header when item numbers are showing will sort the list by item number.
Picking any other column name to sort by that column is the same as clicking on the column’s
header. There is also a button on the tool bar for this function.

Note that when you sort a list, an item’s child items will follow their parent item to its new
position in the list. Therefore, it may look like items are out of order if you look only at the
column you’ve sorted by. These child items will be sorted within the correctly positioned
parent item.

The Ordered List submenu provides two functions that work only in Ordered Lists that are
sorted (See Section 1.11, “Sorting Your Lists” (page 18)): Remove Sorting will remove any
sorting that you’ve done by clicking any of the list’s column headers or by using the Sorting
Window. If the Show item number option is being used, the numbers will be in order when
sorting is removed. Also, if the list is temporarily sorted, you must use this option before
you can move (reposition) list items. Reorder List changes the order of your Ordered List
using the current sort order. This essentially make the temporary sort order permanent.

Filter opens the Filter Bar. The Filter Bar allows you to filter your list items by any column.
Click in the Filter Bar above the column to filter by that column. This menu item changes
to Remove Filter when the Filter Bar is showing, and choosing it hides the Filter Bar and
removes filtering. There is also a button on the tool bar for this function.

Note that when you filter a list, a parent item will be displayed if any of its child items match
the filter, even if the parent itself does not match. In addition, if a parent item matches the
filter, all of its child items will be displayed, regardless of whether they match the filter or
not. Therefore, you may see items in a filtered list that do not themselves match the filter
criteria. These items will be displayed in gray text.

Clear Filters will clear any filters that you applied using the Filter Bar.
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2.2.2. Items Menu

The Items menu also contains these functions to help you use your list items.

Delete Checked Items will delete all the items in the list that currently have the predefined
Checkbox column checked. If you are using the list as a To Do list, this is an easy way to
get rid of all the items you have checked as complete.

Check Selected Items will check the Checkbox column for all items that are currently se-
lected.

Uncheck Selected Itemswill uncheck the Checkbox column for all items that are currently
selected.

2.2.3. Tools Menu

The Tools menu provides these functions to help you customize and use your lists:

The Find menu item on the Tools menu will open the Find window, which allows you to
enter a string to search for.

When you enter a string and push the Find Next button, the next item which contains the
search string in any column will be selected. (Except as described below, the item will be
selected only once, even if it contains more than one copy of the search string.) The list will
scroll to the selected item, if necessary. You can leave the Find window open while you do
other things with the list, if you wish.

If you press the Find All button, ListPro will show you a list of all the items found, rather
than just one at a time.

If the Notes Pane is currently being displayed, individual matches within the Notes column
will be highlighted there. If not, the item with the note will be highlighted to show one match,
even if the value you’re searching for appears more than once in the note.

If you check the Search all lists box, ListPro will search all lists in the file for a match,
otherwise it will search only the currently open list.

If you choose Show only filtered matches, only items that match a list’s current filter will
be found.

If you choose Remove filters first, any matches found in items that are not currently being
displayed will cause the current filter to be removed when the search begins. If no matches
are found in a list, the filter will be replaced (left on).

When searching for a date, be sure to enter the date in the same format ListPro is displaying
dates.
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You can also active the Find and Find again functions using buttons on the tool bar.

Display Totals will show the total of the values in the Amounts column or any Number
column you have added. You will be able to display subtotals by the predefined Units column,
the predefined Category column or any Category column you have added. You can choose
to total all items, or only flagged or checked items. There is also a button on the tool bar
for this function.

Flatten Outline will remove all indentation from indented items in the list. This allows you
to sort child items independently of their parent items. Information about each item’s parent
is stored in a new Parent column. Choosing the Unflatten Outline menu item uses this in-
formation to restore the indentation of each item. See Section 2.6, “Flattening Your
List” (page 38) for more information.

2.2.4. Item Context Menu

When you right-click on a list item, you’ll see the item context menu. This menu provides
functions that operate on the selected items.

Copy to List will copy all currently selected items to an existing list. A window will open
to allow you to pick the list to copy the items into. This functions just as if you had copied
the selected items to the clipboard, opened another list and pasted the items into the list.
Note that the items will be added at the end of the list. This function works best if the
columns of the two lists are similar, because if a column is not the same type as the corres-
ponding column in the other list, the data in that column will be lost.

Move to List is just like Copy to List except that the items are deleted from the current
list after they are copied to the other list.

Autofilter will automatically filter the list using the value of the current column of the cur-
rently selected item (the current column will be the column that you clicked in). Only those
items which have the same value as the selected item in that column will be displayed. The
Filter Bar will automatically be shown if it is not already showing.

2.2.5. List Context Menu

When you right-click on a list in the list tree pane, you’ll see the list context menu. This menu
provides functions that operate on the selected list.

Export to ListPro File will copy the selected list to another ListPro file. This is particularly
useful when you have opened a ListPro file attached to an email and would like to save a
list inside in another file.

Send via Email will copy the selected list into a new ListPro file and attach the file to an
email message. Your default email program will be opened in compose mode with the new
message.
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Open in New Window will create another ListPro window for the current file with the
selected list open. This allows you to work on two different lists in the same file without
having to switch back and forth between them.

2.3. List Columns
ListPro provides many options that you can use to have the information you need in your
lists.

See Section 1.6, “Creating and Editing Columns” (page 11) for more information about
working with Column properties.

2.3.1. Column Customization

ListPro lets you select exactly what columns your lists contain, and the order in which they
appear. Use the List Properties (page 8) window to configure the columns in your list.

ListPro predefines the following columns for every list:

• Checkbox
• Item
• Flag
• Priority
• Amount
• Units
• Category
• Date
• Notes

You can’t delete any of the above columns from your list, but you can choose to hide or
display them. Hide a column by unchecking its box in the List Properties (page 8) window.
Information in these columns will always be available for display (by re-showing the column)
even if the column is hidden.

You can also add your own columns, and you can delete the columns you add. Information
in columns that you delete will be deleted; you cannot get it back. However, if you just
choose to hide a column you created by removing the check from the box next to the column
name, its information will become available again when you re-display it. For more inform-
ation about adding columns, see Section 1.6, “Creating and Editing Columns” (page 11).

The List Properties Window (page 8) also lets you rename and reorder the columns in
your list.

When you’re in the List view, you can sort your list by any column currently being displayed;
tap that column’s header. You can also use the Sort By menu item on the View menu to
sort your list by any column, whether or not it is currently being displayed.
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You won’t be able to edit columns that are Autodate or calculated columns. You’ll only be
able to edit Linked columns in item view, since clicking on them activates them.

The following sections describe some special properties of some of ListPro’s columns.

2.3.2. List Item Numbers

ListPro supports item numbers. This lets you list items in a specific order. To turn on the
item numbers, open the List Properties (page 8) window and check Show item number
on the Settings tab. This is very useful for tasks that need to be done in a certain order. You
can use this feature for any “how-to” types of lists as well as for outlines. Combine order
numbers with Notes for detailed instructions, or use them to be sure you don’t forget an
important step.

Note that while you might not display the item number in your list, all items do have an as-
sociated number (position). You can reposition items in a list (with theArrow Keys orMove
Items Up/Down menu items) when no temporary sorting is in effect. Use the Remove
Sortingmenu item on theViewmenu to remove temporary sorting (only applies to Ordered
Lists (page 18)).

If you have an Ordered List (page 18) and you’d like to automatically reposition all items
using the current, temporary sort order, selectReorder List from the Ordered List submenu
of the View menu. Once the list has been reordered, the order numbers, if showing, will be
in order from top to bottom. You will not be able to return to the original order by picking
Remove Sorting, but you will be able to reposition individual items again. See Section 1.11,
“Sorting Your Lists” (page 18) for more information.

2.3.3. Categories

Categories let you classify your items. Once you’ve entered a value for a Category, that value
is easily selectable as a value for its column.

You’ll often want to sort the items in your list in various ways -- categories let you do this.
For example, you might keep your office supplies in several different cabinets in your office.
You want the supplies on your list sorted by these locations, so that you can efficiently flag
what you need. But then when you go to the office supply store, you’d like your list in the
order you find the items on the store’s shelves. Using one category column for the location
and another for the store you purchase from lets you quickly sort the items as necessary.

Other uses for Categories include: types of music in a CD collection list, kind of restaurant
in a restaurant list, day vs. overnight vs. overseas for a trip packing list, etc.

Sorting by Categories lets you group items in very useful ways. Categories and their values
are saved by the individual list, so that each list can have the Categories and values that will
be most appropriate for that list.
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When editing a Category column, a drop down list of all the current Category Values is
provided. You can either type a category directly or choose it from the drop down list. When
you type in a value, ListPro search the list for a match after you’ve typed in one or more
characters. The first match will automatically be entered into the field you’re typing into. If
the match ListPro finds isn’t what you want, just keep typing. ListPro will keep looking for
matches until you’ve typed enough to identify the right one. Or, if you don’t want any of
the matches ListPro finds, just type in the entire category name. If ListPro puts anything
extra in the field that you don’t want, press the Delete key to get rid of the excess.

Remember that category values are not case-sensitive for sorting or filtering: Hardware is
the same as HARDWARE or hardware.

Note that category values do not have to be just one word. For example, if you have a list
of items you need to pick up, and are using Category for where to get them, you might be
able to get batteries at either a drugstore or a hardware store. You could make an additional
Category column, or just put “drugs,hardware” in your main Category column. Then, if you
Filter your list by either drugs or hardware, batteries will appear. Another option would be
to add more Category columns.

By default, all new values entered for a Category are added to that column’s list of Category
Values. You can also edit each Category’s list of values if you want to add new values or
delete values you don’t need. To do this, select Category Values from the Tools menu,
and you’ll see the Category Values window. Choose the Category whose list you want to
edit from the Category drop down list. To add a new Category Value, enter the value into
the New Value field and push the Add Value button. To delete an existing value, select the
value in the list and push the Delete Value button.

2.3.4. Notes

ListPro’s Notes let you add additional information to a list item. Use Notes for long instruc-
tions, or for details about an item. For example, on an office supply list, the note for a
printer cartridge might contain the model number of the printer.

Remember that you can see and edit the Note for any item even if you don’t have Notes
displayed in the list, using either ListPro’s Notes Pane (select Show Notes Pane from the
View menu), or the Item View (page 14) window (just double-click the item).

2.3.5. Amounts and Units

ListPro’s Amounts feature gives you a powerful numeric column. You can use Amounts to
include any numeric information for items in your list. The Amounts column lets you add
up its information. Use Amounts for anything you might want to count: boxes you’re shipping,
dollars you’re spending, bottles you’re unpacking, ounces, cups, hours, minutes. At any time,
you can display a total of the amounts you’ve entered. In addition, the sum of the amounts
of all items currently being displayed is shown in the Status Bar.
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To make it more useful, you can set up your list to ask for the amounts when you’re “running”
your list (checking items or flagging items for inclusion in a Shopping or Two-Step
List (page 37), perhaps). For example, you can set up your list to ask you for an amount
each time you check an item. This lets you easily track your spending while you’re shopping,
or time spent on each task of a project. Alternatively, you can set up your list to ask you for
an amount each time you flag an item to be included on your List. This lets you enter a
quantity of items to be included on the final list. For example, when you flag "stamps", you’re
asked how many. Then, when you choose the Flag Tool to display your list, the number of
stamps you need appears. To set up these options, use the Column Properties window for
the Amount column. You can open Amount Column Properties either by picking Column
Properties from the column header context menu, or by opening the List Properties window
Columns tab, selecting Amount column and choosing Modify.

The Units column lets you total amounts by unit (using the Totals Window). This is useful
if your amounts are in different units. For example, if you’re using Amounts to track time
on a project, you might sometimes enter minutes, and sometimes hours. If you use Units,
your totals will make sense. Remember that you don’t have to use the units to use Amounts.

2.3.6. Priorities

The Priority column lets you assign a priority number to each item. Priorities have an advant-
age over item numbers because several items can have the same priority number. You can
sort the list by Priority to look at them in order of their importance.

2.3.7. User Defined Columns

In addition to the default columns that you get with every list, ListPro lets you add your own
columns. You can add a column using the Columns tab of the List Properties window. Just
press the Add button to see a menu of column types. You can choose any of the following
column types:

• String – a String column simply holds a string of text, allowing you to enter just about
anything into it. Strings are limited to 255 characters.

• Category – a Category column is like the default Category column. You can enter any text
into it. ListPro will maintain a list of all the values currently used in the column. When
editing the column you can drop down the list of current values and choose one of the
listed values rather than typing in the text. You can also use any category column to get
subtotals when using the Totals window. Remember that Categories are not case-sensitive.

• Yes/No – a Yes/No column works like ListPro’s Flag or Checkbox columns except that
you can choose one of several icons to be displayed in the column. Push the Modify
button to see a window that will allow you to pick the icon to display. Each icon has a set
(yes) and unset (no) appearance and you toggle between them by clicking on the column

35

Chapter 2. Using ListPro



in the list. You can configure your list to clear user-defined flag columns when the list is
reset (page 9).

• 3 State – a 3 State column is similar to a Yes/No column, but it has three states instead
of two (they could also be called Yes/No/Maybe columns). You can select the icons for
3 State columns just like Yes/No columns. Clicking on the column in the list cycles
between the three states.

• Number – a Number column must contain a number. You can use the Totals window to
find the total and subtotals for any Number column. By opening the Column Properties
window for a number column you can also set a Number column to perform simple cal-
culations.

• Date – a Date column holds a date, such as the starting date or due date of a task. Note
that dates appear in the format set by your regional settings (in the Windows Control
Panel).

• Linked – a Linked column holds the name of a file or a URL. The file name can be either
a full path or a partial path beginning from the directory where the current ListPro file is
stored. For example, if the ListPro file is in C:\My Documents\, then a partial path
such as My Pictures\Clouds.bmp would refer to the file C:\My Docu-
ments\My Pictures\Clouds.bmp and a full path such as C:\Win-
dows\Chord.wav would uniquely identify the file regardless of where the ListPro file
is. A URL must always have the proper prefix (http://, ftp://, mailto: or file://) in order
to be recognized as a URL. Clicking on the Linked column in the list will cause the URL
or file to be launched. For example, clicking on a Linked column containing http://www.ili-
umsoft.comNaN will cause your browser to open and show the Ilium Software web site.
Clicking on a Linked column containing “Readme.txt” will open the file ReadMe.txt
in the same directory as the ListPro list file.

2.3.8. Changing Column Type

To change a column's type, open the context menu of the column's header (usually done by
right-clicking on the column header above the column) and chooseChange ColumnType.

Two kinds of column changes are allowed: You may change a Number column to a String
column and you may change a String column to a Category column. Once you've converted
a column, ListPro provides no function to convert it back to the original type of column
again.

If you convert a String column to a Category column, all the current values in the column
are added to the column's category value list (so they will appear in the drop down list that
is used when editing the column).

NaN http://www.iliumsoft.com
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2.4. Two-Step (Shopping) Lists
ListPro allows you to create a type of list we call a “Two-Step” list. Start by creating a new
list and choose the Shopping List template. Once you’ve created your list, choose some of
the items in your list and flag them. Then, select the Flag Tool (or use theView→Hide
Unflagged Items, setting). This will cause only the flagged items to be displayed. You can
treat this list just like any list and check items as you complete them. When you’ve completed
all the items and you reset the list, all the checks and flags are cleared from any items which
have been checked. By default, Flagged items which have not been checked will not be
cleared, although you can also configure the list to clear all the flags or none of the flags
when you reset it.

The best example of a two-step list is a shopping list. When you first create the shopping
list, you enter into the list any of the items you might buy when you do a particular kind of
shopping (for example, office supplies, or groceries). Once you’ve entered your items,
whenever you think of something you need on that list, you flag that item. Then, when you
go to the store, you select the Flag Tool , and the list you see will contain only those items
that you’ve flagged! You then have a shopping list of just those things you’ve decided earlier
that you need. As you shop, you check each item, and, when you’re done, you reset the list.
This clears both the checks and the flags so you can again start flagging items to buy as you
think of them.

Use Two-Step lists any time you want to do (or pick up, or include) only some of the things
on your list. For example, you could make a list of all the places you might need to stop on
the way home. As you think of another stop you need to make, you can flag that item in
your list. Then, when you’re leaving work, you can easily show just the stops you need to
make that day.

Keep in mind that you can add the Flag column to an existing list at any time, or remove it
from a list, using List Properties (page 8).

You can also use the flag column as the second (rather than first) step of a list, by flagging
items for inclusion in another list when you check them. For example, if you create a list of
people you’ve invited to a party or conference, you can check their names as they respond
to your invitation. Rather than duplicating the list when you need to see who will be attending,
you could use the flag column to designate people who will be there. Then, not only can
you easily see who has not yet responded to your invitation (with the checks), you can also
easily see a list of who will be there with the Flag Tool.

Combine Two-Step Lists with other ListPro list features (page 32) and program fea-
tures (page 28) to create powerful lists that really make your life simpler!
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2.5. Changing Fonts
Choose Properties from the edit menu and then select the Format tab to change font
formatting. Press Change next to the font description to open the Font dialog.

For each list, you can select a default list font. For each column, you can choose to use the
default list font or select a custom font. When you change the default list font, all columns
that do not have a custom font selected will display the new default list font. In addition,
the column header names and the Notes Pane will be displayed using the default list font.

Set the default font for your list by selecting a specific font or to use the default font on your
PC, check the Use default system font box.

To change the font for a particular column, select theColumn tab and then select the column
you wish to change and pressModify. Now pressChange and select a specific font or check
the Use default list font box.

2.6. Flattening Your List
If you have a list where you have used indenting to group items, you may sometimes want
to sort the indented items independently of their parent items. The way to do this is to
Flatten the list by choosing Flatten Outline from the Tools menu. Flattening your list will
remove all indentation from all items, allowing you to sort them as equals. A common example
of this is a To Do list in which Priority numbers are assigned to indented items, which are
grouped under parent items that represent different projects or tasks. You would sometimes
like to just sort all the indented items by priority, so you can see the highest priority items
together, independent of project or task.

When you Flatten your list, a new column is created called the Parent column. If you have
more than one level of indentation in your list, a Parent column will be created for each
level. These columns will usually be named Parent, Parent1, Parent2 and so on. The purpose
of the Parent columns is to hold the information necessary for restoring the original hierarchy.
For each item that was originally indented, the Parent column will hold the value of the Item
column of its original parent item. Normally, you can just ignore the Parent columns.

Flattening your list does not simply produce a temporary flat view of your items. The list is
actually changed to a flat list, with information about the original hierarchy stored in the new
Parent columns. This means that there are no restrictions on the type of changes you can
make to your list after it has been flattened. You can sort, rearrange items, edit their contents,
delete items or add new ones. The only thing you need to keep in mind is that any changes
to the values in the Parent columns, or to the Item columns of the original parent items,
may affect the ability of ListPro to restore the original hierarchy of the list.

In most cases you will eventually want to restore the original hierarchy of the list. You can
do this by choosing Unflatten Outline from the Tools menu. ListPro will then use the in-
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formation in the Parent columns to restore the outline. Note that the changes you have made
while the list was flattened may affect how the unflattened list actually looks. For example,
if you have changed the order of the parent items, the unflattened list would reflect the new
order. If you deleted items or changed the order of items that were indented under a common
parent, the unflattened list would contain these changes, too.

It’s also possible that you don’t want to unflatten a list, but have decided you want to leave
it flattened permanently. In that case, you can delete the Parent columns that were created
when you flattened. Please be aware, however, that if you delete the Parent columns ListPro
will not be able to unflatten the list.

Certain lists may not be possible to restore exactly after they have been flattened. For example,
if any of the original parent items have a blank Item column, or if two or more of the original
parent items have identical Item columns, the unflattening operation would not necessarily
have enough information to restore the list exactly. ListPro will always warn you if this is
the case before Flattening, however, so you can avoid flattening a list that can’t be unflattened
exactly.

For more information about Flattening, and an example, see Section 2.6.1, “Flatten Win-
dow” (page 39). For more information about Unflattening, see Section 2.6.2, “Unflatten
Window” (page 40).

2.6.1. Flatten Window

The Flatten Outline window appears when you choose Flatten Outline from the Tools
menu. Use this window to enter the name of a Parent column to use for flattening the outline.

When you flatten a list, all indented items are shifted all the way to the left. This allows you
to sort the indented items independently of their parent items. In order to restore the list to
its previous state where all items are properly indented under their parent items, ListPro
saves the name of the parent items in a new column.

For example, if you have the following list:

and you flatten the list, the list will be changed to look like this:
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If you then sort by Priority, the list will look like this:

You can choose Unflatten Outline from the Tools menu to restore the list to its original
state.

2.6.2. Unflatten Window

The Unflatten Window appears when you chooseUnflattenOutline from theToolsmenu.
Use this window to unflatten a list.

When you unflatten a list that has been previously flattened, the original outline is restored
using the Parent Columns. Unflattening a list causes each item with a value in the Parent
Column to be shifted right one indent level. Each indented item is moved after its parent
item, which is located by finding the item whose "Item" column matches the Parent Column
of the indented item.

Please note that unflattening the list is done using only the information in the Parent Columns.
If you have changed the content of the Parent columns in any items or have changed the
Item column of any former parent items, the unflattening operation may result in a list that
is not exactly the same outline as the original.
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2.7. Using the Keyboard
• Many of ListPro’s functions are accessible from the keyboard. In addition to the regular

menu accelerators, the following keyboard usage is recognized:

• Use the tab key to move between the List Hierarchy pane, the List Items pane and the
Notes pane (if it is showing).

• If you’re doing direct editing, you can use the tab key to tab from one field to the next.
If you use the tab key when you’re direct editing the last column of the last item in the
list, a new blank item is added and its first column is opened for direct editing.

• You can use the space bar to start direct editing on the currently selected item.

• You can use the up and down arrow keys to move the current selection up or down in
the list. If the control key is down when an arrow key is used, the focus item will move
up or down, but the selection will not change. You can then use the space bar to select
or deselect the focus item. If the shift key is down when an arrow key is used, the item
the focus is moved to will be selected in addition to the currently selected items. The Page
Up, Page Down, Home and End keys also function as usual for a list.

• You can use the left or right arrow keys to select an individual column of the current
focus item in the list. The focus rectangle will change to surround only the focus column
rather than the entire item. If you press the space bar when an individual column has the
focus, that column will be opened for direct editing, unless it is a check or flag column.
If it is a check or flag column, the column will be toggled.

• If the current focus item has indented items under it, you can use the plus (+) andminus
(-) keys to expand or collapse the item’s indented subitems.

• Use the Enter key (as well as Alt-Enter) to open the Item View window for the current
focus item.

• Use the X key to toggle the Flag column of the focus item.

• Use the C key to toggle the Checkbox column of the focus item.

• You can use Ctrl-; (Control-semicolon) to quickly add the current date and time to any
note (in the Notes pane only).

2.8. Tips for Using ListPro
Use ListPro for any kind of list: instructions, tasks, shopping. It’s especially useful for steps
in a process you do frequently, but that doesn’t recur at regular intervals, for example, releasing
a new product. Special features for shopping lists (page 37) create another very useful way
to use ListPro. Ordered lists combined with Notes give you a way to record detailed instruc-
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tions. Resetting your list lets you easily use lists over and over. Categories and Notes let you
group items in many ways.

Use ListPro as a powerful, multi-level Notes organizer. Use the item column as your note
titles, and put your notes into the Notes column for each item. Then organize the notes into
lists, folders and list files, just the way you want them.

Use ListPro as an outliner by turning on the Show item number option (in List Properties)
and dragging items to the right to indent them.

You can easily move lists between files using the Clipboard. Just select a list in one file,
copy it, and paste it into another file. You can have ListPro running more than once to make
this even easier. You can also use the clipboard to move items between lists. See Section 4.2,
“Using the Clipboard” (page 50). You can also copy lists from another file using Import
Lists on the Tools menu.

You can sort the items in your lists by any column, just by clicking the column header.

Use the Notes Pane to see and edit longer notes or add information to items. You don’t
need to have the Note column selected for display in the list – the Notes pane will show
this information for the selected list item.

To quickly enter information into lists, display only the columns for which you’ll be entering
information. You can always choose to show other columns later, but they’ll be out of the
way while you’re doing data entry.

To easily copy or paste just the information you want, hide some columns using the List
Properties (page 8) window, use your clipboard to copy the remaining information, then
show the columns again. To make it even easier, first move all columns that you want to
copy to a position ahead of the ones that are turned off. See Section 4.2, “Using the Clip-
board” (page 50) for more information.

You can use the column header context menu to do all your column rearranging. Right click
on the column header above a column to see the context menu, then pick Hide Column
to hide the column or pick Show Column to show a column after the current one. Drag a
column header to the right or left to order the columns.

Use the user-defined Yes/No columns to make your to-do list into a useful table. For
example, if you need to do a multi-step cleanup on several different computers, you can
make each step a list item and each computer a flag column. Then you can easily mark each
step as it’s complete for each machine. This is also useful for releasing several products,
testing on several platforms, etc.

Note that category values do not have to be just one word. For example, if you have a list
of items you need to pick up, and are using Category for where to get them, you might be
able to get batteries at either a drugstore or a hardware store. You could make an additional
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Category column, or just put drugs, hardware in your main Category column. Then, if you
Filter your list by either drugs or hardware, batteries will appear.

Make your lists more readable by changing the fonts in each column.

ChooseHide Checked Items (or its button on the tool bar) to hide items you’ve checked,
if you only want to see what you still need to do.

Check Ilium Software’s website for new sample and useful lists1. You can use the Import
List Wizard to easily import these lists into your ListPro file (choose Import Lists from the
Tools menu).

A simple way to make it easy to tell which items in a list have been completed is to set a
different color for checked items. Open the List Properties window and go to the Color
tab. Press the Change button next to Color for Checked Items and choose a new color.
Setting checked items to a gray color is a good choice because it makes the completed items
look like disabled choices.

Use theMake Backupmenu item from the Filemenu to easily make a backup of the current
ListPro file. It’s a good idea to do this regularly, especially if you’re using File Synchronization
to synchronize with a mobile device. You never know when you might want to retrieve
something you deleted accidentally.

To start ListPro with a specific file open, double-click on the file in Windows Explorer.

New lists that you create can have the columns, fonts and settings you’d like -- and to make
the choices automatically available every time, just make the appropriate changes to the lists
in the Templates (page 24) file.

Highlight your most important items in Item View or by right-clicking on a list item.

You can directly manipulate lists simply by dragging items, column headers and list names.

See Section 2.7, “Using the Keyboard” (page 41) for helpful information on keyboard
shortcuts.

2.8.1. Preferences

On the Windows PC or Pocket PC, use Tools → Preferences to change the following list
of behaviors.

• Enable alarms for this file on this device: check to enable alarms for this ListPro file

• Confirm deleting list items: check to see a confirmation dialog box when you delete a list
item

1 http://www.iliumsoft.com/listx
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• Confirm deleting lists and folders: check to see a confirmation dialog box when you delete
entire lists or folders

• Confirm resetting lists: check to see a confirmation dialog box when you reset a list

• Prompt on moving items in Ordered List: check to see a dialog box with options when
you try to move items in a sorted, ordered list (page 59)

• Confirm clearing columns: check to see a confirmation dialog box when you clear an entire
column

• Confirm remove filter on adding items: check to see a confirmation dialog box when you
have a filter in place and attempt to add new items

• Hide flag column on hide unflagged items: check to have the flag column disappear when
you select View → Hide Unflagged Items, or when you click the flag button
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Chapter 3. New Features
ListPro 5.0 introduces a number of great new features that we’re sure you’ll find helpful.

3.1. Linked Files Location
ListPro 5.0 makes it easy to link to files and also to share those files with your Windows
Mobile Device. This is handled by the new Linked Files Location. The Linked Files Loc-
ation is a special place for storing files that you have linked to with ListPro. By default, the
My Documents folders on your Windows PC and your Windows Mobile Device are set
as the Linked Files Location.

Keep in mind that the Linked Files Location is a place where ListPro looks for linked files and not a special
ListPro folder. You won’t find a folder called "Linked Files".

The Linked Files Location serves a couple of different purposes:

• When you go to link a file in ListPro, the Linked Files Location is the first place it offers
you to choose files from. This makes it easy to know where to place files that you want
ListPro to link to. Just drop them in the Linked Files Location on your device, and ListPro
will find them when you go to make a link.

• The second purpose is that when you go to Publish a list, ListPro looks in the Linked
Files Location for files that your ListPro list is linked to. If it finds them, you can have it
move the files over to your Windows Mobile Device along with the list itself.

3.2. Link Options
You can change some of the settings for your Linked Files Location. To do so, select the
Link Options menu item. On your Windows PC you will find this under Tools. Your
Windows Mobile devices has Link Options as well.

Please note that all Link Options are advanced options. Unless you feel very comfortable with changing settings,
you should not change any of these.

The Link Options window lets you choose from the following options:

• The location of the Linked Files Location

• Only showing files from the Linked Files Location

• Choosing whether to publish linked files from the Linked Files Location

Choose Linked Files Location: You can change the location of the Linked Files Location.
To do so, either enter a new path into the field provided, or browse to the new location with
the Browse button. Files from the old location are not automatically transferred; you will
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need to do this manually. ListPro lists linked to files in the old location, however, will auto-
matically know to look in the new location. You do not need to make any changes to your
lists.

Only Show Linked Files Location Files: By default, ListPro only offers files in the Linked
Files Location when you go to link a file. If, as an advanced user, you wish to also link to
files in other locations, you can turn that option on by unchecking the box labeled Only
show files in the linked files location. Please remember that files in areas other than the
Linked Files Location are never published to your mobile device.

Choose to Publish Linked Files: You can choose whether ListPro publishes the files in
the Linked Files Location that you’ve linked to. By default this is on but if you would like
to turn it off, uncheck the box labeled Publish linked files.

3.3. Rich Text Notes
With ListPro 5.0 you can add rich text formatting to the notes pane for items. This formatting
will display in both the List View and the Item View. In addition you can add bullet points
or numbered points to your notes pane.

Rich Text Formatting: To format text in your notes, higlight the text you would like to
change and then right-click on it. Select Format from the menu. The options provided in-
clude:

• Font

• Font Size

• Bold, Underline, and Italic

Formatting will display on your Windows Mobile Smartphone and Pocket PC as well, and
you can change or add formatting on your Pocket PC also.

Bullets and Numbering: You can add bullets and numbering to text in your notes pane.
Right-click where you want your bulleted or numbered information to appear. Select Para-
graph from the menu. From the window that appears you can choose None, Bullets, or
Numbered. As you enter text, each time you hit enter, a new bullet/number will be created.
Hitting enter without typing any text will end the bullet/numbering.

3.4. Live Links in the Notes Pane
ListPro 5.0 lets you add live links to the notes pane of a list item. To do so, simply highlight
the text that you want to turn into a link, and then right-click on it. Select Insert Link from
the menu. In the window that comes up you can set what text you want to display in the
notes pane as well as where you want to the link to go.
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By default, we include http:// since this function is primarily used for web links, although
you can enter any valid path into this field including links to files stored on your computer.

3.5. Add Pictures to the Notes Pane
With ListPro 5.0 you can now put pictures in the notes panes of your items. With this feature
you can include images of the covers of books in your book collection list, add pictures of
the people in your contact list, or include a map graphic in a list of your favorite restaurants.

To add a picture to your notes pane, right click in the notes pane of an item. Select Insert
Picture from the menu. This brings up a window showing you all the images currently stored
in your Linked Files Folder. Click on the picture you want to appear in the notes pane of
your list, then click the Select button.

Next, choose how you would like the picture aligned. Select Inline to have the picture appear
inline with the rest of the note text, Align left to align it along the left side of the notes pane,
or Align right to align the image along the right side of the notes pane.

3.6. Export to HTML, XML, and RSS
ListPro 5.0 offers new ways to share your lists. You can now create attractive HTML ver-
sions of your lists that are viewable in any web browser. This is a great way to share your
lists with friends, or even as a means of publishing them on the web. You can also export
lists in XML Format, as well as ready-to-publish RSS Newsfeeds.

To export using these new formats, select Export Items to File from the Tools menu. In
the export window, you can select HTML or XML from the Export format drop-down
list. In addition, you can select an Export style for your exported lists. These styles vary
according to the type export format you’ve selected.

• Tab-Delimited Format

• NoColumnNames: The column headers are not included in the tab-delimited export
file.

• Column Names in First Row: ListPro includes the column names as the first row of
the exported file.

• CSV Format

• NoColumnNames: The column headers are not included in the tab-delimited export
file.

• Column Names in First Row: ListPro includes the column names as the first row of
the exported file.
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• Indented Text Format

• NoColumnNames: The column headers are not included in the tab-delimited export
file.

• Column Names in First Row: ListPro includes the column names as the first row of
the exported file.

• HTML Format

• Default Style: The information exports in a style defined by a CSS format we’ve in-
cluded with ListPro. This gives the lists an attractive appearance. Advanced users may
decide that they want to replace our CSS format with their own.

• Non-CSS: The list is presented in a raw HTML format with no CSS formatting.

• RSS Format

• Default Style: The information is exported using standard XML formatting.

• OPML: The list is exported in OPML formatting.

• RSS: This will export your list as a ready to publish RSS format file.

3.7. Publishing Lists
ListPro 5.0 adds a new feature called List Publishing. With List Publishing you can send
your lists, and the files you’ve linked to in those lists (including pictures,) over to your Win-
dows Mobile Device. To publish a file, connect your Windows Mobile Device to your
Windows PC, then open that file in ListPro on your Windows PC. Next, click on the Publish
icon . In the window that appears, click the Publish button, and ListPro does the rest.

If you have any trouble publishing your lists, make sure that the file is closed on your Win-
dows Mobile Device. To do this, simply navigate to the document list (using Show Files on
the Smartphone or by clicking OK in the upper right corner of the screen on Pocket PC)
before publishing. Also, keep in mind that only files stored in the Linked Files Location will
get published to your device.
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Chapter 4. Information Exchange and
Synchronization

4.1. Information Exchange
You can export (page 52) your list file information to a text file to use with other programs
with theExport Items to Filemenu item. This will copy information in the currently selected
list to the file you specify. You can also import list items from a text file into an existing list
with the Import Items from File menu item. The Import Lists menu item will allow you
to import lists from another ListPro file.

You can create a new list (page 54) using columns and items from the current list with the
Export Items to List menu item. If you right-click on an item in a list to show the item
context menu, you can choose Copy to List or Move to List to send items to another
list (page 54) in the file.

Use the clipboard to easily:

• move or copy items from one list to another

• move or copy lists from one file to another

• move or copy lists within a file

You can copy one item, several items or an entire list to the clipboard. Make sure the list
you are pasting into has the same set of columns as the list you copied from. You can also
paste ListPro list information into a text file or an Excel worksheet. Text information from
another source can be pasted into ListPro in the same tab-delimited format used for exporting
and importing. See Section 4.3, “Importing and Exporting Lists” (page 52) for more inform-
ation.

If you have a Windows Mobile device with a copy of ListPro installed, you can read any list
file with either ListPro version. You could, for example, enter information using your Win-
dows PC version of ListPro, then copy your list file to your Windows Mobile device for easy
access to your lists anywhere.

Please note that while you can use File Synchronization with ActiveSync 3.5 (or later versions)
to automatically copy the most current version of your file between platforms, ListPro does
not support individual record synchronization with ActiveSync. That is, you cannot update
one item or list in a file on your Windows PC and another on your Pocket PC and have both
changes take effect. Only whole files are synchronized. Be sure to close ListPro on both
platforms before synchronizing files. See Section 4.5, “File Synchronization” (page 55) for
more information.
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In addition, some Windows Mobile-based Smartphone do not support File Synchronization,
so you must manually copy files to these devices in order to share lists between platforms.
See the Section 4.6, “Smartphone” (page 56) section for more information.

If you have a Palm OS handheld, you can use HotSync to synchronize your ListPro inform-
ation between your Windows PC and your handheld device. See Section 4.7, “HotSync with
Palm OS handhelds” (page 56) for more information.

4.2. Using the Clipboard
You can easily use your system’s Clipboard with ListPro to:

• move or copy items from one list to another

• move or copy lists from one file to another

• move or copy lists within a file

• paste items from other programs into your ListPro lists

To copy a list, simply select the list name, and copy it to the clipboard. You can then paste
it elsewhere within the same list file, or into another list file. You can also move the list directly
by dragging it with your mouse if you want to put it into another folder or another position
in your current list file.

You can copy selected items to your clipboard, for pasting into the same list or into another
list, or for pasting into another program.

4.2.1. Copying from List to List

When copying and pasting from one ListPro list to another, ListPro uses the following rules
to determine which columns from the first list to copy into columns of the second list:

• If both lists have columns of the same type and are in the same order, all information for
all columns will be transferred, including information in columns not showing.

• If that is not the case, ListPro compares the columns that are currently being displayed
in each list. Starting from the left, data in all columns is transferred as long as the columns
have the same type. If a column is found that is not the same type, data in that column
and all columns to the right of it are not transferred.

• Indent Level and Highlight color are always transferred to the new list. Indent Level may
be adjusted based on where an item is pasted into the new list, but the items pasted will
retain their Indent Levels relative to each other.

• The Notes column is always transferred, regardless of whether it is showing or not.
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4.2.2. Copying From a List to Another Program

If you are transferring items to another program, only the columns currently selected for display in
a list will be copied. The currently displayed columns will be copied to the clipboard in the order
they are currently being displayed in the list. You can control which columns are copied and
pasted and the order they appear using the Columns tab of the List Properties (page 8)
window. Highlight color is never transferred.

If an item is indented, the Item column that is copied to the clipboard will contain a tab
character for each level of indentation so the column will appear properly indented when it
is pasted.

Checkbox, Flag and Yes/No columns are copied to the clipboard as 1s if selected (checked
or flagged) and 0s if not selected. Three State columns are copied with a value of 0, 1 or 2.

4.2.3. Copying Tips

Tip

Note that Columns selected for display (in the List Properties (page 8) window)
are usually the same as those currently being displayed in the list area. However,
if the Flag column is selected for display and you have the Hide Unflagged
Items option selected, the Flag column may not be showing, but it will be
copied/pasted as if it is showing.

Tip

If you want to easily copy or paste fewer columns than are currently being dis-
played, just hide those columns using the List Properties (page 8) window, use
your clipboard, then show the columns again. If you first move all columns that
you want displayed before the ones that are turned off, it’s even easier to turn
the ones you want back on. You can also hide and show columns by right clicking
on the column header to see the column header context menu and pickingHide
Column and Show Column.

4.2.4. Pasting Into a List From Another Program

Pasting items into a list follows the same rules as copying them from a list: data is only pasted
into the columns that are showing. However, if you have copied a set of single-line text strings
containing no tab characters, you can paste them into an open list, and the information will
be pasted into the Item column.

When pasting into the Item column, leading tab characters will indicate that the item is to
be indented.
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Checkbox, Flag and Yes/No columns may be skipped when pasting in the text. If the data
in the position for one of these columns is not a 1 or a 0, the column will be skipped and
the data will be pasted into the next non-flag column.

4.3. Importing and Exporting Lists
You can use ListPro’s import capability to make lists out of data you currently have in other
forms. You can also export your lists to text files for use with other programs.

When you choose Import Items from File from the Tools menu, ListPro displays the
Choose Columns to Import window. This window lets you choose which columns to import
the data into. Any of the currently displayed columns can be chosen, as well as the Notes
column and the Indent Level. You can also choose the order the columns will be found in
the file, and you can skip the first row of the file if it contains column names.

When you chooseExport Items to File from theToolsmenu, ListPro displays the Choose
Columns to Export window. This window lets you choose which columns to export. You
can choose any of the currently displayed columns, as well as the Notes column and the
Indent Level. You can also choose the order the columns should appear in the file, and you
can export the column names in the first row of the file. You can choose to export all items
in the list or only those that are currently showing.

List items are imported and exported to files in Indented Text, tab-delimited, or comma-
separated-value form. Indented Text and tab-delimited files use the extension .txt and
comma-separated-value files use the extension .csv. Each field you want to import must
be separated from the previous field by one tab character in .txt files or by a comma in
.csv. Indented Text files differ from tab-delimited files in that the Item field contains a
tab character for each level of indentation. If a field contains a new line (that is, a carriage-
return/line-feed or hard line break) or a comma, the field must be enclosed in quote (")
characters. If a quote character appears in a field, it must be replaced by two quote characters
and the entire field must be enclosed in quotes.

Note that Columns selected for display (in the List Properties (page 8) window) are usually
the same as those currently being displayed in the list area. However, if the Flag column is
selected for display and you have the Hide Unflagged Items option selected, the Flag
column may not be showing but it will be imported and exported.

Item order for export will be set by the order of the items in the list. By default, all items in
the list are exported, but if you choose Only export currently showing items, only the
items currently being displayed will be exported. If you choose that option, any items not
currently displayed (due to being Flagged, Checked, Filtered out or collapsed) will not be
exported.

If ListPro fails to import a file that contains dates – showing an error message about
“invalid format for field” -- make sure that your system’s date format setting matches the
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format in the file. For example, if you have dates in a CSV file in MM/DD/YY format, but
your Windows PC’s date format is set to CCYY-MM-DD, ListPro will consider the
MM/DD/YY dates to be invalid. To get around this situation, just change your system’s
date format (Start Menu → Control Panel → Regional and Language Options) to
match the formats in the file you’re trying to import. After importing it to ListPro, you can
then change your settings back.

If you need assistance on setting up information to be imported into a list, first create a very
small (two- or three-item) version of the list you want, and export it to a file. Then edit the
file using a text processing or spreadsheet application, and import it back into ListPro. When
you can get the right information to import into the right columns, you have found the right
format. This will help you create the import format correctly.

Checkbox, Flag and Yes/No columns are exported as 1s if selected (checked or flagged)
and 0s if not selected. Three State columns are exported as 0, 1 or 2.

You can import items from a file that was created by exporting from an older version of
ListPro by following the steps below. However, please note that ListPro will automatically
convert your older list files for you, so you probably don’t need to import their information.

To import lists from files created by version 2.0.x of ListPro, use the Choose Columns to
Import window to arrange the columns in the order they appear in the file. The Indent Level
will always be first, and the others will be in the order they appeared in the list.

To import lists from files created by versions of ListPro older than 2.0, use the Choose
Columns to Import window to arrange the columns in the following order:

1. Amount

2. Units

3. Item

4. Category

5. Notes

If you want to, you can use import and export to move information from one ListPro column
to another. For example, if you want to move the information from the Notes column of a
list to a new column you’ve called Info, you could export all columns of the list (including
Indent Level and Notes) to a file. Then make a new list with the Info column, and import
all columns except Notes, with Info in the position Notes had been in. This will move your
information from the Notes to the Info column.
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4.4. Information Transfer Within ListPro
ListPro has several functions for transferring lists between files and for transferring items
between lists.

4.4.1. Transferring Lists Between Files

When you choose Import Lists from theToolsmenu, ListPro starts the Import List Wizard.
This wizard guides you through importing folders and lists from other ListPro files. The
wizard will ask you to choose another ListPro file and will then allow you to choose the
folders and lists you want to import. All selected folders and lists will then be imported into
the current file.

You can also copy a list from your current file into another ListPro file. Right click on the
list name in the list tree view to show the list context menu. Choose Export to ListPro File
and ListPro will let you choose a ListPro file to export to. The list will then be copied to the
other file.

4.4.2. Transferring Items Between Lists

When you choose Export Items to List from the Tools menu, ListPro displays the Export
to List window. This window allows you to enter a name for the new list to export into, and
to choose which columns to export. Any of the currently displayed columns may be chosen,
as well as the Notes column. You may also choose the order the columns should appear in
the new list. You may choose to export all items in the list or only those that are currently
showing.

You can also copy or move items to an existing list. Right click on an item in the list to show
the item context menu. Choose Copy to List or Move to List and ListPro will let you
choose another list in the current file to send the items to. The items will be appended to
the end of the chosen list. In addition, Move to List will delete the items from the current
list once they have been copied. These functions work best if the destination list has columns
the same or similar to the current list so ListPro knows where the data goes. For example,
if the other list has a number column in the position where the current list has a string
column, the data in that column will be lost because it’s the wrong type for the new column.
Using these functions is just like copying or cutting items to the clipboard and then pasting
them into another list, so the rules for copying columns is the same as for using the clipboard.
See Section 4.2, “Using the Clipboard” (page 50) for more information.

4.4.3. Emailing a List to another ListPro user

You can easily send a ListPro list as an attachment to an email. Right click on the list name
in the list tree view to show the list context menu and then choose Send via Email. ListPro
will create a new ListPro file and copy the selected list into it. Your default email program
will then be started and a new email will be created with the new ListPro file as an attachment.
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You can then address the email, compose your message and send it to another ListPro user.
When the recipient opens the email he can open the attachment in ListPro to see the list
you sent.

4.5. File Synchronization
If you have a Pocket PC, you can use File Synchronization to keep the list files on your PC
in sync with the list files on your mobile device (if you have a Smartphone, see Section 4.6,
“Smartphone” (page 56)). We recommend you install the latest version of Microsoft Active-
Sync.

You can keep lists on both your desktop and Pocket PC and keep them in sync, using Mi-
crosoft ActiveSync. First of all, ensure that you have ActiveSync installed and that it’s the
latest version. Then follow these steps:

• Enable File Synchronization: On the desktop, open the ActiveSync window and select
Tools, Options.Check the "Files" box and Click "Ok."

• Now, for each ListPro file that you want synchronized, open it on the desktop and then
start the synchronization wizard, using File, Synchronization. The wizard will guide you
through a few basic steps (including moving your Windows PC ListPro file to the syn-
chronized folder.)

• On the Pocket PC, new files that you create and store in the synchronized folder are
automatically sync’ed with your Windows PC.

Tips for Synchronizing

Although ActiveSync can operate in "continuous sync" mode -- meaning that it
synchronizes files whenever a change occurs, we recommend that you use "Only
upon connection" or "Manually" as your sync choices.

If you have a ListPro file open on your Pocket PC when synchronization occurs,
you may see a message that the file is in use. If that happens, close the file and
sync again.

We recommend that you close the ListPro program on the desktop before
syncing.

If you don’t want a file synchronized any longer, simply move it out of the syn-
chronized folder on your Windows PC. To see where this folder is, open the
ActiveSync window, select Tools, Options, highlight "Files," and click on "Set-
tings."
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If you have more than one mobile device, you’ll probably have more than one
Synchronized Files folder on your Windows PC. The drop down list at the bottom
of ListPro’s Open File window lets you to choose which one to use.

4.6. Smartphone
If you have ListPro on your Microsoft Windows Mobile-based Smartphone, you can share
your ListPro files between your Windows PC and your mobile device. Unlike other Windows
Powered devices, however, Smartphones currently do not support File Synchronization, so
you can’t use ActiveSync File Synchronization to automatically synchronize these files.

To share ListPro files with your Smartphone, you must manually copy the files between your
Windows PC and your Smartphone. To do this, choose Explore from the ActiveSync window
to open the Mobile Device window. Then open Windows Explorer in another window and
locate the folder where you keep your ListPro files.

• To copy a ListPro file from your Windows PC to your Smartphone, select the file in the
Windows Explorer window and pick Copy from the Edit menu to copy the file to the
clipboard. Then go to the Mobile Device window and pick Paste from the Edit menu to
copy the file from the clipboard to the Smartphone. Or you can simply drag the file from
the Windows Explorer window to the Mobile Device window.

• To copy a ListPro file from your Smartphone to your Windows PC, select the file in the
Mobile Device window and pick Copy from the Edit menu to copy the file to the clipboard.
Then go to the Windows Explorer window and pick Paste from the Edit menu to copy
the file from the clipboard to your Windows PC’s folder. Or you can simply drag the file
from the Mobile Device window to the Windows Explorer window.

4.7. HotSync with Palm OS handhelds
With Record Synchronization (currently only available for Palm OS handhelds), you can
make simultaneous changes to different list items on your desktop and mobile device and
both changes will be synchronized. Follow the steps below to set up your desktop and
Palm OS handheld for synchronization:

• Start the Synchronization Wizard by selecting Synchronization from the File menu.

• The Synchronization Wizard will allow you to select an existing ListPro file on your
desktop to synchronize with your handheld – either the file you already have open or a
different one.

• Also use the Synchronization Wizard to indicate that you want to Synchronize with a
Palm OS handheld, and how you want the lists synchronized the first time.
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When to useSynchronization
Options (first time)

You have important information in your desktop ListPro file and
are not worried about the existing lists on your Palm OS device.

this PC overwrites
your device

All the ListPro information on the Palm OS device will be replaced
with the desktop ListPro information.

You have important information in both your desktop ListPro file
and in the lists on your Palm OS device.

this PC combines
with your device

You have important information in the ListPro lists on your
Palm OS device and are not worried about the existing information

your device over-
writes this PC

in your desktop ListPro file. All the ListPro information on the
Desktop will be replaced with the Palm OS deviceListPro inform-
ation.

• Perform the HotSync function on your Palm OS device to synchronize your data. If you
just installed ListPro on your handheld, you may need to synchronize twice: once to
transfer the ListPro application to the device and once to synchronize the data. Synchron-
izing twice is only for installation; for normal use you will only need to synchronize once.

• Note that after you’ve completed these steps ListPro obeys whatever synchronization
rules you have it set for in the Custom settings of HotSync (the default is to combine
items).

Only one ListPro file on the desktop can be synchronized with a Palm OS handheld.

If you don’t want a desktop ListPro file synchronized with your Palm OS handheld any
longer, you will need to uninstall the ListPro Conduit. If you need any assistance in unin-
stalling the ListPro Conduit, please contact our Product Support.

If you are using ListPro for a Microsoft Windows-based Pocket PC, see Section 4.5, “File
Synchronization” (page 55). If you are using a Microsoft Windows-based Smartphone, see
Section 4.6, “Smartphone” (page 56).

4.8. Printing
You can print your lists using the Print menu item on ListPro’s File menu. The list that is
currently selected will be printed. If a folder is selected, all lists in that folder will be printed.
If you have selected the root item at the top of the list tree, all lists in the file will be printed.

If you’re printing just one list, print the entire list using the Print All option on the Print
window. Select one or more items in the list and use the Print Selection option to print only
specified items in the list.
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Check the box labeled Print all items in list if you want to print all items rather than just
displayed items. Check the box labeled Always print Notes to force the Notes column to
be printed, even if it is not selected in the List Properties window. If you check the box
labeled Print Notes below item, the Notes column will be printed in its entirety (word
wrapped onto several lines if necessary) on one or more lines below the rest of the item’s
columns.
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Appendix A. Ordered and Unordered Lists
When you create and use lists in ListPro, you can be working with several general kinds of
information. “List,” after all, is a pretty broad term. One sharp distinction among kinds of
lists, though, is simply:

Does order matter?

In other words, is there some reason why item a has to come before item b? Does it make
a difference if the items in your list stay in the order you entered them? Or is your list more
like a generalized data base, where having one permanent order isn’t important, but being
able to sort and rearrange items temporarily is? ListPro can handle both of those general
kinds of list for you. Here’s how to choose which one.

Unordered lists are now the default in ListPro, and you should use them for most of your lists.
When would you want to use an ordered list? Here are some possible examples:

A list of steps in a procedure, where the order of performing them is important. Consider
changing a tire on your car:

1) Loosen lug nuts
2) Jack up car
3) Remove wheel
...

If those steps get out of order:

3) Remove wheel
1) Loosen lug nuts
2) Jack up car
...
trouble could ensue. But consider a more complicated procedure, one requiring multiple
groups to coordinate:

ResponsibleItem
QA dept1) Create test plan
Product management2) Review test plan vs requirements
QA dept3) Respond to test plan comments
VP software development4) Sign off on test plan
Development5) Deliver test version 1
QA dept6) Execute test plan
QA dept7) Enter defects in defect system
Development8) Review assigned defects
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ResponsibleItem
...

The items should be carried out in that order, but you might want to resort them, temporarily,
by the “Responsible” column, in order to get a list of each group’s responsibilities. But you’d
want to be able to get back to the original order.

A.1. Is Your List Ordered or Unordered?
If you’re looking at an existing list, there are several ways to tell if it’s been defined as ordered
or unordered.

• Sorted Indicator: If the list is sorted on one or more columns and you see an arrow, up
or down, in the column heading, you have an ordered list.

• Ordered List Box: If the Ordered List box in the list properties is checked, you have an
ordered list.

• Move or Indent Items Dialog Box: If you are attempting to move items up, down, left,
or right and you see the “Move or Indent Items Dialog Box,” you are working with an
ordered list.

A.2. Unordered Lists
The default in ListPro is to create what we call “unordered lists.” Items go into the list one
by one, with each new one either appended to the end of the list or inserted at a point of
your choosing. But they don’t retain that order permanently.

Drag it right to indent it un-
der the one above it, and it
becomes item number 2a

You can drag the first one
down to the middle of the
list; item one becomes item
number 3

So, if you enter items like this:
(the numbers are ListPro’s item
numbers - turn them on with
List Properties, Settings)

1. item two
2. item three

1. item two
2. item three

1. item one
2. item two

a. item one3. item one3. item three
3. item four
4. item five

4. item four
5. item five

4. item four
5. item five

The resulting order is the new order of the list. There’s no command to go back to the ori-
ginal order (with a few exceptions - you can undo the last move you made, and of course,
you can manually re-arrange the records. But you can’t just click a button and go back to
the original state.) That’s true of both unordered lists and ordered ones; however:
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If we sort the unordered list, the item numbers change to follow the new order

1. item five
2. item four
3. item three

a. item one
4. item two

Again, there’s no automatic way to return to any of the previous states. That’s the basic
meaning of creating an unordered list – sorting is forever.

A.3. Ordered Lists
If order is important, ListPro lets you define a list as an “ordered list” (with List Properties,
Settings). What that means is that the order of items is considered permanent, and although
sorting can appear to change it, the old order remains in place, and you can go back to it.

But, if you sort the list now, you
see that the items move on the

...you can still move them
around, and the item numbers

So if you enter items in
an ordered list...

display, but the numbers remain
as they were

change, just as with an un-
ordered list

4. item five
3. item four

1. item two
2. item three

1. item one
2. item two

2. item threea. item one3. item three
a. item one

1. item two
3. item four
4. item five

4. item four
5. item five

Your ordered list is now in what we call Sorted View Mode. From this mode, you can revert
to the list’s numbered order by selecting View, Ordered List, Clear Sorting. You can sort
the list in any way that makes sense, and still get back to your original order.

However... While the list is in Sorted View Mode, you can’t move items up or down,
left or right. That would make it impossible for ListPro to revert to your previous order. If
you try to move an item, you’ll get a dialog box explaining that you can’t do what you’re
trying to do, and giving you a set of options for what to do next.

You can:

• Remove the current sort order (just like selecting View, Ordered List, Clear Sorting).

• Make the current sort order the list’s permanent order (just like selecting View, Ordered
List, Reorder List).

• Make this list not an ordered list (like changing it with List Properties, Settings).
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• Or, you can simply click “Cancel” and leave things as they are now.

(If you don’t want to see this again, you can choose one and make it the permanent choice.)
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Appendix B. Customer and Technical Support

B.1. How to Contact Ilium Software
Information and Sales

For Technical or Customer Support, Sales or general queries, please visit our web site.
If you have a question, the best way to reach us is via the contact information below.

Support
For Technical or Customer Support, visit our Support1 area, or reach us using the contact
information below.

Contact Information

Use our secure web server at www.iliumsoft.comWeb:

www.iliumsoft.com/contactusEmail:

Ilium Software
3759 Prospect Rd.
Ann Arbor, MI 48105 USA

Mail:

1 http://www.iliumsoft.com/support
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